I got This error

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:
sudo certbot --nginx
It produced this output:

My web server is (include version):
nginx version: nginx/1.18.0 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu Server 22.04
My hosting provider, if applicable, is:
Go daddy
I can login to a root shell on my machine (yes or no, or I don't know):
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 2.9.0

Your site needs to be accessible over port 80 on the public internet.


The IP addresses in your DNS look like you have a URL Redirect (or URL Forward) service enabled in GoDaddy DNS

You need to disable that service and then set an A record to point to the public IP for your nginx server. Please ask GoDaddy support or see their docs about how to do that.

Your DNS right now

mi-prueba.online.	0	IN	A
mi-prueba.online.	0	IN	A
mi-prueba.online.	0	IN	A
mi-prueba.online.	0	IN	A

That sounds like what @Geno11x11 was just wrestling with. I wonder if he can offer a suggestion on how to make the necessary change.


Yes. This same issue repeats on this forum often. It is the first thing I look for if I see GoDaddy hosting and an IP address starting with '3.' in the error message :slight_smile:


In my case, the first step was to remove Domain Forwarding, a pretty easy step. I followed the instructions at this site: Remove my domain forwarding | Domains - GoDaddy Help US . The web page appearance differs but the headings and path to DNS Management work as described.

Next, under the Domain DNS heading, I discovered my domain had been 'Parked' by GoDaddy after I deleted Domain Forwarding. If you find that A-record labeled 'Parked', delete it.

Finally, I made a mistake when creating my A-record under DNS Management by entering the text URL while creating my A-record. If you have selected the Domain name you wish to work on (displayed at the top of the page), you cannot repeat that Domain name in the A-record. Instead use '@' in the 'Name' field. Do not include the squotes ' ' in your A-record entry.

Once completed, it took about an hour for propagation.


Excellent description. Thanks @Geno11x11

I am going to link to this for future cases.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.