WordPress - Need To Update Static Assets Such as Images after Swapping to HTTPS

Hi!
My Hosting provider does not support Let’s Encrypt Certificates.
But I found an installation guide that worked almost perfect for me.
The article I am referring to can be found here:

I didn’t run any commands myself. Instead I used the following plugins:
WP Encrypt
Really Simple SSL
SSL insecure content fixer

I’d appreciate any suggestion.
Thank you

Please fill out the fields below so we can help you better.

My domain is:
ekeen.press

I ran this command:
none

It produced this output:

My web server is (include version):
cpsrvd 11.58.0.49

The operating system my web server runs on is (include version):
libmysql - 5.1.73

My hosting provider, if applicable, is:
namecheap

I can login to a root shell on my machine (yes or no, or I don’t know):
I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

Let’s Encrypt will not remove images from your site. Does the site have any images at all, because I can’t find any.

The only reference to img that I can find on your site is:
var checker_IMG
within a function.
try inserting a simple image on your home page.

direct request to https://ekeen.press/wp-content/themes/business-elite/images/Contact_us.jpg
fails with 404

The images fail with IE/EDGE/Chrome/Firefox
Your site is doing some kind of “copy protection” that is 100% effective - lol

If you do have a site with images and then can’t see them after turning on HTTPS, it might be because of mixed content blocking.

(However, blocking insecure images isn’t a default behavior in popular browsers; they’re considered “passive mixed content”. Someone would probably have to opt in to this more aggressive form of mixed content blocking in the browser.)

A helpful testing tool to diagnose mixed content problems is at

https://www.whynopadlock.com/

Thank you for responding.
Yes, the site has many images. That’s the point…
Not even the themes images or logos of the plugins I use are being shown after following the guide posted above.
The front page had two sliders at the top that turned black completely. I had to disable them for now.

And above every post listed, there should be an image as well.

Thank you for responding.
I haven’t tried to upload a new image yet.

Among various other functions, the following are directly from your site:

function disableSelection(target)
{
//For IE This code will work
if (typeof target.onselectstart!=“undefined”)
target.onselectstart = disable_copy_ie;

//For Firefox This code will work
else if (typeof target.style.MozUserSelect!="undefined")
{target.style.MozUserSelect="none";}

//All other  (ie: Opera) This code will work
else
target.onmousedown=function(){return false}
target.style.cursor = "default";

}

function disable_copy(e)
{
var elemtype = e.target.nodeName;
var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
elemtype = elemtype.toUpperCase();
var checker_IMG = ‘’;
if (elemtype == “IMG” && checker_IMG == ‘checked’ && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
if (elemtype != “TEXT” && elemtype != “TEXTAREA” && elemtype != “INPUT” && elemtype != “PASSWORD” && elemtype != “SELECT” && elemtype != “OPTION” && elemtype != “EMBED”)
{
if (smessage !== “” && e.detail == 2)
show_wpcp_message(smessage);

	if (isSafari)
		return true;
	else
		return false;
}	

}

function disable_copy_ie()
{
var elemtype = window.event.srcElement.nodeName;
elemtype = elemtype.toUpperCase();
if (elemtype == “IMG”) {show_wpcp_message(alertMsg_IMG);return false;}
if (elemtype != “TEXT” && elemtype != “TEXTAREA” && elemtype != “INPUT” && elemtype != “PASSWORD” && elemtype != “SELECT” && elemtype != “OPTION” && elemtype != “EMBED”)
{
//alert(navigator.userAgent.indexOf(‘MSIE’));
//if (smessage !== “”) show_wpcp_message(smessage);
return false;
}
}

The point is that the images appear not to be on the server. Even the image on the 404-page is missing: https://ekeen.press/wp-content/themes/business-elite/images/404.png . I’d suggest to reinstall the themes and plugins you’re using.

Uploaded images are also missing: the folders under /wp-content/uploads are all empty. You’ll need to upload the images again.

Thank you schoen.
I have used the ssl checker recommended in the article.
This is the result:
Done. Total pages crawled: 8
No issues found

The article is suggesting that the broken content might point to http and should be changed to https.
Unfortunately, this is not the case. All links in the media library point to https. Yet no images are displayed in the library (I am using Wordpress, by the way).
Also the theme’s images and plugin logos are also broken.
I have the latest version of Mozilla installed.
I followed the link you posted at the end:

I know very few about coding and programming (you might have already noticed that ;).
Can the issue be related with the themes css ? Or is there anything I can do by making changes through my cpanel? After all the images should be there somewhere, right?

Thank you all for helping!

But how did that happen?
Did you have a chance to read the article I posted at the beginning?
I have no idea what I did to delete the images from the server by following the guide. After all, the plugins did most of the job. I only had to download the certificate’s files and paste them into the plugin wp encrypt.

I did a backup before starting to install let’s encrypt.
Could I undo the site’s encryption and try it a second time by doing anything different?

Oh, yes. I use a plugin for content protection.

Does this one have something to do with the images being deleted?

Yes, I believe it has something to do with it.

Would it help if I’d remove it now or is it too late?

I’m sorry. I just realize that you’ve included a code for me to use.
Where do I need to paste the code?

no that code was from your site - not for you to add to site
just to show you where I think the problem is.

Oh, ok.
You might be right. Deactivating it doesn’t work. Any suggestions here?
Thanks a lot, again! This plugin is a variable I didn’t think of at all…

try re-enable http and see if content appears for http but still not for https.

Images just loaded!!! Yay!

That’s what I did:

The content protection plugin is still enabled.
But I disabled the Really Simple SSL plugin and loaded one post using http.

Now, I didn’t grant the plugin access /permission to the .htaccess file because this might cause a problem. Might this have been the issue?

OK that means the plugins aren’t broken.

But the site must be doing something special with the images…
That it’s doing in http but not in https.
Can you see the any of the underlying code?
or it’s all via control panels?

The only code I can access through Wordpress, is the theme’s.
If you can guide me through, I can try to find the underlying code in the cpanel.