WordPress - Activiating Let's Encrypt for HTTPS But Not Updating All Content to HTTPS Causes Errors

RESOLVED***
Installed though cpanel.
Theme icons are in a subfolder of the theme.
When I activate Let’s Encrypt - all the icons are gone.

How to I install in the theme subfolder (if that is the solution) or how do I correct this break in the load of the icons?

626fitness.com

@Merlin16, I was trying to check your site but the only I get is:

Your access to this site has been limited
Reason: Access from your area has been temporarily limited for security reasons.

It’s not quite clear which “icons” you are talking about specifically, but your pages seem to reference some resources, such as CSS and images, via http://

When the page is loaded via HTTPS://, those resources will not be loaded because of the “Mixed content”. If you google for it, you will find plenty of resources in regards how to fix it, for example this one (since you’re running WP):

1 Like

My clients has country blocking, so you may be in one of the countries she’s blocked. If you provide your country or ISP, I can unblock you. Thanks

I have followed all the suggestions I find on Google. I also read this article and one of the suggested plugins hasn’t been updated in years, so I opted for a newer one., Force SSL. Same problem.

Before posting to the community:
I had a the premium version of Simple SSL and it allegedly set all the non https assets to relative, didn’t fix the problem.
I had also checked through Chrome Developer and get these type of results.: 626fitness.com/:1 Mixed Content: The page at ‘https://626fitness.com/’ was loaded over HTTPS, but requested an insecure font ‘http://626fitness.com/wp-content/themes/pluto/assets/fontsglyphicons-halflings-regular.ttf’. This request has been blocked; the content must be served over HTTPS.
I had also changed the settings in the Generals settings to https.

The icons that don’t show when Let’s Encript is activated are the arrows, social media icons, post icons, etc.
I have not had this problem with any other site, but this one. I inherited this site and the client loves her theme so changing the theme is not an option.

hi @Merlin16

If you run the site through here: https://www.whynopadlock.com/check.php

It will give you all the assets that are currently been served over HTTP. You need update your pages to get them from HTTPS rather than HTTP

Once that is done you should get the greenlock and see the icons etc

Andrei

THANK YOU.
I’ve been combing this site manually and completely forgot about whynopadlock.
Found the offensive file, corrected it and all is good.

Thank you

I APOLOGIZE FOR BLAMING LET’S ENCRYPT.

@Merlin16,

Appreciate it but I’m not motivated to help someone who thinks they’ll be safer by blocking my country (Spain).

Anyway, @leader and @ahaw021 already gave the clue to solve your issue so I’m glad you fixed it.

Cheers,
sahsanu

I apologize if you feel offended by my new client’s country blocking. I doubt it is anything personal against you or your country. She lost her ecommerce site last year to hacking and since her new business only deals with local clients, she is simply limiting her exposure.
Wishing you all the best.

2 Likes

Hi @Merlin16

A) It’s ok to assume a change (applying a Let’s Encrypt certificate) may cause an issue
B) I am happy with the way you dealt with the issue (listened and investigated other reasons why)

Andrei

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.