WordPress Not Using HTTPs After LetsEncrypt Certificate was Obtained


#1

Hey dear community :slight_smile:

I just installed the Let’s Encrypt! Certificate via my host All-Inkl on my domain premiumbands.de (which is a wordpress based website - the current wordpress version which I cannot find out as I can’t log in…read below).

Now I’ve got a problem: The front page shows up with the https:// , but when I click one of the menu items, blog articles or any page different from the home page, it gives me a 404 telling me that “The requested URL was not found on this server”.

Problem is that I also cannot log into the admin panel because there’s just the same issue. When I click “log in”, it’s a 404.

What can I do? It’s a commercial website which is responsible for a lot of my marketing, so I would appreciate to solve this problem as fast as possible :smiley:

Thanks in advance for your support!
Dom


#2

Hi @dom123,

I’m sorry to say that this is not a Let’s Encrypt problem and instead has to do somehow with the configuration of your server or WordPress. (They may have made a significant mistake in their own Let’s Encrypt integration, but we’re not in a position to fix that for them.) You should probably contact support for your host instead.

I hope you succeed in getting the problem resolved quickly.


#3

@dom123

Looks like you solved the problem. How did you do that?

It’s good for the community to have a collection of solutions. I am assuming you needed to add HTTPS links in your wordpress?

Andrei


WordPress Configuraiton File Needs Update After Let's Encrypt is Installed
#4

You are perfectly right! I was sitting until 4 am when I asked a friend who has done several SSL verifications for websites before, and he sent me some articles. The problem was really just to (inside the WP-Backend) go to “Settings --> General” and put the https:// instead of the http:// on both fields.

Problem was only that I told my server to “force https whenever http is addressed”, before I did the step described above. This way, nothing worked anymore and I couldn’t change the necessary settings (which I didn’t know at that time).

So my way was:

  1. STOP forcing the http to https redirection in my host.
  2. Log in with the http (the https still did not work!)
  3. Go to Settings -> General and exchange the paths.
  4. Be happy that everything works out fine again.

Hope this will help further users!

Best wishes to you all, and thanks for your replies :slight_smile:
Dom


Migrating WordPress with HTTPs Secured by LetsEncrypt to New Server
#5

Thanks Dom

There have been a few queries around wordpress and one of the tools that has come out has been https://github.com/rlankhorst/really-simple-ssl which does the updates for you

Andrei


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.