Let's Encrypt certificate is issued and verified, website not using it

I am in the process of creating a portal for my son to play with (gametips4gamers.com). Part of the setup I am trying to setup SSL. The server is a Ubuntu 16.x server setting up a WordPress site.

The process to setup the encryption was completed successfully, however, my browser is not showing the site as secure. The site would flash secure for a moment, then will show not secure.

If I test the site on SSL Labs, it passes.

What am I missing?

Thank you for your time.

Take a look at the source code of your website. All the resources are being loaded by IP address:

<link rel='stylesheet' id='twentyseventeen-style-css'  href='' type='text/css' media='all' />

When the site is accessed over HTTPS, this is not going to work, because the browser will refuse to load that content.

Change your WordPress Site URL to the proper URL (https://gametips4gamers.com):



I tried to make the changes in the code, but it did not help. I then took a closer look at the admin portal and found the settings to make the changes you suggested.

Once I made the two updates to the site, it worked!

Thank you for your help. Have a great weekend.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.