My lets encrypt ssl site not secure


#1

My domain is: https://dammamgroupholdings.com/

I ran this command: tried visiting my page

It produced this output: it showed not secure when the certificate is on

My web server is (include version): dunno

The operating system my web server runs on is (include version): dunno

My hosting provider, if applicable, is: Dreamhost

pls how do i get it to be secure always.


#2

Hi @tusirius

your certificate is valide and installed. But you have a lot of mixed content warnings, you load content via http, not https.

Use Chrome or FireFox, then CTRL + Shift + I, that opens the console.

There you see a lot of lines with warnings:

http://www.dammamgroupholdings.com/wp-content/uploads/2018/08/dammam-logo-transparent3-1.png

Change these to https.

I don’t use WordPress. But perhaps there is an addin to do that automatic.


#3

There’s a setting (or two actually) to set the URL of the site. It includes http:// by default. Changing that to https:// should fix all the basic WordPress linking. But a malfunctioning plugin can always mess things up.


#4

That may be one problem. There are links

http://dammamgroupholdings.com/wp-content/uploads/2018/08/dammam-logo-transparent3-1.png

and

http://www.dammamgroupholdings.com/wp-content/uploads/2018/08/dammam-logo-transparent3-1.png

so the same content is loaded via www and non-www.


#5

Thank you all for your help… It was actually the mixed content problem. Used a plugin to correct them all because they were so many…thanks once again


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.