Info or Not Secure title with valid SSL Certificate


#1

Hi there,

I’m running a one-click WordPress site hosted by Vultr on Ubuntu 16.04 x64. I have a validated SSL certificate through Let’s Encrypt for the site www.gegc.ca though I am getting an “Info or Not Secure” icon instead of the padlock.

I ran a check on whynopadlock.com and it showed everything was in shape besides having an outdated TLSv1 protocol enabled that I don’t think is the issue though still a bit fresh and unsure.

I’ve also updated the WordPress general settings for the site addresses to be “https” and not “http”.

I don’t know what my next step should be in troubleshooting so any and all guidance in solving this issue is appreciated.

-Michael


#2

What’s the exact URL that you see the warning on? Is it just the home page?

Can you take a screenshot of your full address bar with the URL and warning visible?


#3

Hi _az

its both www.gegc.ca and gegc.ca on all the pages.

I’m in the process of restoring it back to a previous snapshot so it may not be accessible at the moment.


#4

It looks like right now, your site is not configured to redirect from HTTP to HTTPS. If you go to the HTTP version (http://www.gegc.ca), you’ll see Not Secure, because that’s what Chrome displays for HTTPS pages.

If you go to the HTTPS version (https://www.gegc.ca), you’ll see a green padlock in the address bar, but the contents of the page don’t render correctly. That’s because you are referencing those contents by IP address rather than by domain name, and you don’t have a certificate for that IP address. For instance, you are loading one resource as https://216.155.152.158/wp-content/uploads/2018/11/Flooring-3.png. I believe you need to go into your WordPress admin settings and change the base URL for the site to be your domain name rather than an IP address.

You can see some of the blocked requests by opening the Chrome developer console and reloading the page.


#5

jsha can’t thank you enough for the help.

I’ve gone into Wordpress admin panel and changed the Wordpress url to www.gegc.ca and the site url to gegc.ca

I was hoping this would fix the issue but it still isn’t showing the padlock but the site is rendering properly.

Is it possible to obtain a certificate for the IP address or how can I go about fixing the issue?


#6

Hi @msdux

now you have fixed the wrong links.

A certificate with an ip address isn’t required. Use the domain name.


#7

As of this morning, I see both the padlock and a properly rendered site. Did you get everything working?