I dont know why my site doesnt have a green padlock


#1

Dear community,
I have following problem:
My site is secured with a SSL-certificate from Lets encrypt, however the green padlock doesnt show.
It returns the message, that some elements are still unsecure. However i am clueless how to fix that.
I checked with a padlock checking site, it returns all is good.
Thank you very much for your help!

Best regards,
ceehaa

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://dealcuatui.com

I ran this command:

It produced this output:

My web server is (include version): Dont Know. This is my hosting provider: all-inkl.com

The operating system my web server runs on is (include version): I don’t know

My hosting provider, if applicable, is: all-inkl.com

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Wordpress v.4.9.8


#2

Hi @ceehaa,

Normally that means that you’ve included some resources in your page over HTTP instead of HTTPS, such as scripts, stylesheets, or images. This is called a mixed content problem.

You may be able to diagnose it with a tool like

https://www.whynopadlock.com/

or with the web developer tools in your web browser.


#3

It’s not the issue with the certificate. You can check status of the cert by checking in Inspect element in the browser.

You have elements like images, scripts and other resources still tagged with HTTP. You need to modify the tags to HTTPS.

To Convert the site to HTTPS, just adding the cert is not enough.

Cheers
Rajesh


#4

Green in the padlock or address bar usually implies that an EV cert is being used.
LE only provides DV certs which show a lock but only on a regular white background.

Please show the message (or link to site that shows the message).
All I see is:
“Get Ready… Something Really Cool Is Coming Soon”


#5

Thank you all for your reply!
I tried finding http as a search keyword when inspecting the site, however there are a lot of hits. I am pretty clueless how to find these “links or images” tagged with http.
Second question is how can i modify these to https if i found them all?

@rg305: The site is now accessible: https://dealcuatui.com

Would be great if you could share how I can solve this problem. I am pretty new to this subject.
Thank you all!


#6

Hi @ceehaa

use FireFox or Chrome, then Ctrl + Shift + I, that opens the console. There you see all wrong links.

http://dealcuatui.com/wp-content/uploads/2018/11/dealcuatui_logo_v2_greenfett.png

In Wordpress, there are options to change these links global (but I don’t use Wordpress).


#7

Correct, in the WordPress Admin, in the “Settings” section you’ll find two options in the “General” settings subsection:

  • The “Site Address (URL)” setting is the address you want people to type in their browser to reach your WordPress blog.
  • The “WordPress Address (URL)” setting is the address where your WordPress core files reside.

In those variables, change “http://” to “https://” and press the “Save Changes” button on the bottom.


#8

Thank you very much Osiris, I changed that.
@JuergenAuer, thank you too. That helped a lot! I try changing the links. :confused:


#9

A post was split to a new topic: Site doesn’t have a green padlock