New SSL installation does not show green padlock


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:pinhasov.com

I ran this command:

It produced this output:

My web server is (include version): IIS 8.0

The operating system my web server runs on is (include version): Windows Server 2012 R2

My hosting provider, if applicable, is: softsyshosting.com

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk


#2

Hello Support,

We tried installing the Let’s encrypt SSL on our website “pinhasov.com” from the Plesk panel. Once SSL is installed, it shows the susccessfull message but the browser does not show green pad lock.

Please assist,
Regards,
Munaf Sheikh


#3

Hi,

Please use this website to determine:
https://www.whynopadlock.com/

Thank you


#4

Hello

I am getting https://www.whynopadlock.com/results/8f3b39c7-e958-4348-962d-e9690e6b8299 Plesk self sign certificate details.

We have install/renew Let’s Encrypted certificate for domain pinhasov.com. We are getting successful message after install, but it’s not secure while browsing. Can you please advice it?

Thanks
Mayur


#5

Hi @support_user,

Is your Plesk instance provided by your hosting provider?

You’ve successfully issued several valid certificates

https://crt.sh/?Identity=%pinhasov.com&iCAID=16418

but we can see with a browser or with the whynopadlock site that those certificates have not been installed into your IIS server. If you expected Plesk to perform that step for you, maybe your hosting provider could investigate and explain why it didn’t?


#6

Hello

Is your Plesk instance provided by your hosting provider?
Ans: We are providing hosting service to our client.

I am not sure that it is related to issue of Let’s encrypt or Plesk. We would like to renew Plesk default certificate or else since I cannot see name of Lets Encrypt pinhasov.com in IIS >> server certificate.


#7

All of the certificates that you’ve obtained are still valid. You don’t need another one; instead, you need to get one of the already-issued certificates to be used by IIS. I thought maybe you were expecting that Plesk would do that for you, if it was Plesk that obtained those certificates.


#8

Hello

I have also tried to install Let’s encrypt SSL certificate in other domains and getting same issue. We are getting successful message, but it will not work with https. Also, I cannot see SSL cert in server certificate (IIS). It means is there an issue with Plesk or Let’s encrypt configuration or setting?


#9

I think it’s a problem with Plesk. Either Plesk is not really able to install certificates in IIS, or else its ability to do so isn’t working properly on your system.

If you’d like, you could post a new topic on this forum mentioning Plesk and IIS in the subject, which might attract interest from people with some relevant expertise; otherwise, I would suggest asking on a Plesk forum.

The reason I say there’s no problem with Let’s Encrypt is that your certificates were issued successfully and are still valid, covering the names that you requested. They just aren’t in use by your instance of IIS.


#10

Hello

I have fixed this issue. There is an issue with Plesk itself. But website is still showing self singe certificate while browsing https://pinhasov.com/ . I confirmed that Let’s encrypt certificate showing in binding as well. Do you know why it is still showing wrong cert while browse?


#12

Hi,

When i’m visiting your site, the certificate is coming from Parallels Panel.
Maybe you can check with your host or anywhere to find that? (probably need to install from that panel)


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.