Certificate shows valid but the website still shows not secure


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://astrologerlovespells.com/

I ran this command: Using TurnKey hosting and installed the certi with the letsEncrypt app

It produced this output: “The connection to the site is not fully secure”

My web server is (include version): Shared Linux hosting

The operating system my web server runs on is (include version): Linux

My hosting provider, if applicable, is: Turnkey

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes.


#2

Hi,

You have successfully installed the certificate, however, because you are using wordpress. You have a few more things to do…

First, Go to your admin panel -> settings -> general. Check the two site address (site address & admin address), change both from http to https. Then refresh your website (without cache).

Secondly (this is optional), Add this to your .htaccess file. Before # BEGIN WordPress
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

This should keep your wordpress site away from mixed content.

Thank you


#3

Hi Steve,

Thanks for the reply , i have done both the steps but still the same issue.
The website “https://astrologerlovespells.com/” is going to https but the secure symbol is still missing…
And it says “your connection to this site is not fully secure”


#4

Hello @Kaashvigarg

use the Webmaster tools from FireFox or Chrome, there the console.

There are some http - links:

http :// astrologerlovespells . com / wp-content/uploads/2018/06/number_img.jpg

Change them to https.


#5

I have changed all the http links to https but stil the same issue.

Can you please have a re look at “https://astrologerlovespells.com/


#6

Hi,

Do you use a page builder by any chance?

Do you added the http to https code in the .htaccess (Step 2)? If so, this problem shouldn’t occur…

Thank you


#7

Use the webmaster console. It’s a tool which is very helpful dealing with SSL.

Chrome: CTRL + Shift + I

Same with FireFox.


#8

Thanks this resolved the issue , there was one hidden link which was not showing in view source…


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.