Timeout issue - sorry, I'm new to this stuff


#1

My domain is:

dwccloud.uk www.dwccloud.uk

I ran this command:

sudo certbot --apache

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel): www.dwccloud.uk dwccloud.uk
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.dwccloud.uk
http-01 challenge for dwccloud.uk
Enabled Apache rewrite module
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. dwccloud.uk (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://dwccloud.uk/.well-known/acme-challenge/sIM2RPA9e0yrnIBTMXnf6I3yGlLa_AEjVSupDpX-WMw: Timeout during connect (likely firewall problem), www.dwccloud.uk (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://www.dwccloud.uk/.well-known/acme-challenge/Hewvgk_HeelzWU5m2Sdur04Qza9FyciuaAtTT6u-rKg: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:

My web server is (include version):

Apache2

The operating system my web server runs on is (include version):

Ubuntu 16.04

My hosting provider, if applicable, is:

homeserver

I can login to a root shell on my machine (yes or no, or I don’t know):

yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

no


I ran my domains through Let’s Debug and got this:

ANotWorking
Error
dwccloud.uk has an A (IPv4) record (86.63.4.185) but a request to this address over port 80 did not succeed.
A timeout was experienced while communicating with dwccloud.uk/86.63.4.185: Get http://dwccloud.uk/.well-known/acme-challenge/letsdebug-test: context deadline exceeded

Trace:

Making a request to http://dwccloud.uk/.well-known/acme-challenge/letsdebug-test (using initial IP 86.63.4.185)
Dialing 86.63.4.185

and this:

StatusNotOperational
Warning
The current status as reported by the Let’s Encrypt status page is Service Disruption as at 2018-05-09 17:12:15.52 +0000 UTC. Depending on the reported problem, this may affect certificate issuance. For more information, please visit the status page.
https://letsencrypt.status.io/

and this:

InternalProblem
Warning
An internal error occured while checking the domain
An unknown issue occured when performing a test authorization against the Let’s Encrypt staging service: acme: no nonce sent



#2

Hi,

That means your firewall / isp / router is blocked / blocked / misconfigured.

Port 80 and Port 443 can’t be connected from outside.

Please check your Router Redirection rule as well as firewall settings.

Thank you


#3

Hi Stevenzhu,

Thank you very much. I’ll get right on it.

Kind regards,

Peter


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.