Http-01 challenge, Timeout during connect (likely firewall problem)

My domain is: mcwin-cloud.asuscomm.com

I ran this command: sudo certbot --apache -d mcwin-cloud.asuscomm.com

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Requesting a certificate for mcwin-cloud.asuscomm.com
Performing the following challenges:
http-01 challenge for mcwin-cloud.asuscomm.com
Waiting for verification...
Challenge failed for domain mcwin-cloud.asuscomm.com
http-01 challenge for mcwin-cloud.asuscomm.com
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: mcwin-cloud.asuscomm.com
    Type: connection
    Detail: Fetching
    http://mcwin-cloud.asuscomm.com/.well-known/acme-challenge/L3z-DstH1Zi4scZ-GTDcSGIk9xSQ8jGjOVXCz4fVDgo:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you're using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): apache2

The operating system my web server runs on is (include version): Debian 11.2.0

My hosting provider, if applicable, is: self-hosted

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.12.0

I recently installed Nextcloud 23 on a new server I built. The other day I had successfully installed my Nextcloud instance and was able to get the ssl installed successfully. However, the day after I had continued to harden my server only to find out that I broken the connection. I had continued to receive HTTP 500 Errors. Despite trying to back track and undo what I had done, I was unsuccessful. I ended up wiping the wiping the hard drive and reinstalling Debian 11.

Fast forward, today I was able to get Nextcloud reinstalled and I'm able to access it through HTTP. I ran the command I entered above only to receive that error message listed in the output.

I have an Asus router with Asuswrt-Merlin installed. Port forwarding was enabled on both port 80 and port 443. I'm using DDNS through Asus. I had the option to obtain an SSL through my router for Let's Encrypt so I tried that and re-ran the command, didn't work.

Every possible combination I could think of as far as settings go I've tried. Removed and readded port forwarding profiles on the router; editing firewall and even as far as disabling the firewall on my server and on my router completely. Ran the command again and that still didn't work.

I've no exceeded the number of attempts to obtain and install a cert using certbot. I'm a noob so I'm sure I have missed something completely, somewhere in the process.

1 Like

Looks like you do not have port 80 open or a firewall blocking http requests. Also, the domain asuscomm.com is subject to rate limits right now so beware of that. See below for details of both

3 Likes

From the Internet?

3 Likes

I'll take another look to see what is blocking it. When I "disabled" all of the firewalls, I could have very easily missed something somewhere.

1 Like

I'm just realizing now that I don't have access to my cloud outside of my own network. I'm currently on a friends wifi and I'm not able to access it. There is clearly something else that is wrong here that I'm missing. I'll start with my port 80 being blocked and go from there. If I have a port 80 problem I should probably solve that before my ssl problem.

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.