Timeout during connect

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: gamercraft.ga

I ran this command: certbot certonly -d gamercraft.ga

It produced this output: How would you like to authenticate with the ACME CA?

1: Spin up a temporary webserver (standalone)
2: Place files in webroot directory (webroot)

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 1
Plugins selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for gamercraft.ga
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. gamercraft.ga (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://gamercraft.ga/.well-known/acme-challenge/7CQj-JzVXi5oAit0m5w3BOx2P61q953__n9fF3WZUy4: Timeout during connect (likely firewall problem)


  • The following errors were reported by the server:

    Domain: gamercraft.ga
    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): nginx version: nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version): ubuntu 18.04

My hosting provider, if applicable, is: self-host

I can log in to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

The first time I did it with another domain it worked after I changed domains and reset the server i get this error, if I try to connect to it I get connection refused
edit: troubleshooting steps: tried resetting my router, disabled the ufw
edit 2: ok update, only happens when Nginx is down. problem is neither nginx being disabled or enabled fixes this

If you’re running nginx, why are you using certonly with the standalone authenticator? Why not just use the nginx plugin? If you’re not comfortable with certbot changing your nginx configuration files permanently, you could always only use the authenticator part of the nginx plugin without using the installer part with -a nginx. Note: nginx has to be running to use the nginx certbot plugin.

This site is going to be used as a control panel (pterodactyl is a popular open source game panel) for a minecraft server and was following the guide on their website https://pterodactyl.io/tutorials/creating_ssl_certificates.html

the other time i did it it worked

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.