The SSL certificate works on desktop but does not work on mobile

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Hi @sphacor !

Welcome to the community!
For what it is worth, I CAN see your site just fine...


I see it is fine on web however the mobile version, if you try does not display the lock, and I have tried all possible options that I can think of, please help.

1 Like

Works fine on my Android mobile using Chrome.

Please explain the issue you're having more extensive, perhaps using a screenshot.

Also, try cleaning your cache for example.


One thing that stands out is that it looks like you have some "mixed content" that may be causing your issue. That would be something like: in your code.

Check out this link and it should point you in the right direction.


You may also want to take a peek at this:


Okay I will have a look. I am usign the good cloud platform so the ip address but it is masked to point to I will also check the link you provided.

1 Like

Ok I had a look but here my concern is, that I have created the SSL certificate using wherease I see that other folks are seeing IP address. Now the IP address does not have the SSl attached whereas the domain is. This ip points to the

1 Like

There are 3 areas of concern here. One is that image that @Rip pointed out above.
Another image, is the WhatsApp image - also served over http.
The 3rd is that you have TSLv1.0, v1.1 & v1.3 enabled. You should disable TSLv1.0. Web browsers, especially some mobile browsers will simply refuse to connect to your site if TSLv1.0 is being served. It is no longer secure.


Thank guys for the help and input. I am kind of new to this web word and so I not well acqauinted here. I am sorry but the image you have mentioned about, may I know how that image i sa matter of concern? And in this case why SSL is behaving separately on web versus mobile if that image was the matter of concern t? U will also look at the TSLv1 as well.


Looking the beginning of the URLs for both images, you'll see they begin with http and not https. That's the problem. It's called mixed content. The http links are unsecure. Change those two links from http to https and that should clear that up.


Thanks for that Jim... I'm sure I could and should have taken the time (when I had it) to give a better explanation.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.