Not secure on mobile

Hi, Newbie here. I'm sorry if this has been answered before but I couldn't find anything on here with my exact problem. I enabled HTTPS using the Lightsail HTTPS instructions
and I'm getting a secure site on desktop with no problems but on mobile, it's not secure. I have an iPhone XR and have tried chrome and edge. I also tried on my partner's phone which is an iPhone 13. We have the latest apps installed. I'm a complete newbie in this space and would love some help. Thanks heaps.

I hope I answered the below correctly.

My domain is:

I ran this command:

It produced this output:

My web server is (include version): AWS lightsail Wordpress?

The operating system my web server runs on is (include version): Linux

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don't know): YES (I think) that's how I installed the HTTPS with BERT TOOL

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): BERT TOOL.

Thanks Josh

1 Like

You have mixed content. There are some (seven) images on your homepage that are loading over http instead of https.

I don't know why wordpress would add them this way to your posts (did you add your certificate only recently?) but you should edit the posts to make the images load over https (or use a plugin that does that for you: this should work, but I have not tried it)


Hi @9peppe you are amazing. I downloaded 'Really Simple SSL' and it fixed it in like 2 seconds. Thanks heaps.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.