SOLVED - Redo "first time" certbot certificate installation - start over


#1

Ubuntu 16.04 headless server with root ssh access
nginx/1.10.3

Hi, I have a question:
Is there a way to start over with certbot?

I installed my certificate somehow in the beginning, don’t remember how to be honest. I didn’t have nginx working yet and just tried to get a certificate to get nginx working. It was a bit of a “quick and dirty” action.

Currently

certbot --nginx
works fine. I did let certbot do changes to my nginx configuration.

but somehow

sudo certbot renew --dry-run
doesn’t run through.

I do not really want to fix this specific issue but to “start over”.
Is there a way to start over, from the beginning with certbot.
Certbot works fine on all my other servers and I just must have messed up this one.

I am really sorry if I am not posting my domain name here. I just don’t want it linked to any forum.
I hope it’s ok as I consider this a more generic question.

Greetings, Chris


#2

Yes, you can start over by fully removing /etc/letsencrypt . Back it up first to preserve your existing certificates, keys and accounts.


#3

Thanks a lot _az

That was exactly what I was looking for.

Now everything works perfect with “certbot renew”.

I just needed to properly configure everything with a bit time :wink:

Have a good weekend!