Let's Encrypt worked. Attempted renewal dry run fails

I looked at another post here that had the error, but it was because they turned off http. Another post talked about getting a more recent certbot client.

I’m on Ubuntu 16.04 LTS and using nginx.

Just set this up today by doing the following:

sudo apt-get update
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:certbot/certbot
sudo apt-get update
sudo apt-get install python-certbot-nginx

Then I used this command to get a certificate for one of my websites:

sudo certbot --nginx

That all worked! My site is serving up with https:// and no issues. NICE.

Now I’m testing the dry run cert renewal by doing:

sudo certbot renew --dry-run

And it fails with the message in the screen shot below:

Any ideas on how to trouble shoot? Thank you!

This is a known bug. It was fixed in Certbot 0.16.0, the latest release; unfortunately, the PPA is still on the slightly older 0.14.2. :sweat:

1 Like

Thanks man! So how can I get the updated version of certbot? I’ve read somewhere you can possibly grab it from Github, but I don’t know how to do that.

Well, you can follow the “Ubuntu (other)” instructions to install and use up-to-date certbot-auto.

I don’t really recommend it. It’s easy and it will work, but it’s a bit awkward. It will install a second copy of all of Certbot’s dependencies (some apt packages, and some things in root's home directory). You’ll have to adjust the Certbot package’s “certbot renew” systemd timer to run certbot-auto instead.

Downgrading Certboti n the future could potentially cause compatibility issues. (I don’t think it will currently, but i’m not certain about the Nginx configuration parts, and it it’s subject to change in a future release.)

This isn’t that critical a bug. And the PPA will likely be updated before your certificates expire. :stuck_out_tongue:

Still, it’s up to you, and easy to do.

1 Like

Thanks @mnordhoff - I’ll wait and hope for the update.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.