NXDOMAIN looking up TXT for _acme-challenge.mydomain.net

Hi, I have similar problem. But my problem’s details say;

Detail: DNS problem: NXDOMAIN looking up TXT for
_acme-challenge.mydomain.net - check that a DNS record exists
for this domain

But I added the related record and check it with dig. The record was created and I was taken.

What can I do for this situation?

1 Like

Hello. I’ve moved your post to a new topic.

That can happen for multiple reasons. Often it’s because the DNS service has a large number of servers and some of them have the new record but some don’t yet.

Can you fill out the questionnaire below?


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

2 Likes

Can you provide the command you are running ?

1 Like

Thank you for carrying the title

My domain: servicepark.net
I ran this command:

./certbot-auto certonly --manual --preferred-challenges=dns --email notification@servicepark.net --server https://acme-v02.api.letsencrypt.org/directory --agree-tos -d *.servicepark.net

It’s produced this output:

Press Enter to Continue
Waiting for verification…
Challenge failed for domain servicepark.net
dns-01 challenge for servicepark.net
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: servicepark.net
    Type: dns
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.servicepark.net - check that a DNS record exists
    for this domain

My web server version: I don’t know
Operating System: Windows Server 2012
I can login to a root
I’m not control panel but I know who controls
Certbot version: certbot 1.1.0

I also checked the TXT file with the command

dig _acme-challenge.servicepark.com.tr TXT

and I see _acme-challenge and my TXT record is same.

1 Like

Hi @tara

that’s the .net domain, not the com.tr. The com.tr has a TXT entry, but not the .net.

Domain name *.servicepark.net -> _acme-challenge.servicepark.net TXT is required.

3 Likes

Thank for your attention. We have a few domain for servicepark and we set up for .com.tr

We changed the set up and certbot is work!
Thanks a lot of

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.