[Solved]DNS problem: NXDOMAIN looking up TXT for _acme-challenge


#1

Hey there,

Im working the entiteit dat to get my wildcard goong, but I not able to solve my challenge issue.

My domain is: ccvitaal.nl

I ran this command:~$
sudo certbot certonly --server https://acme-v02.api.letsencrypt.org/directory --manual --preferred-challenges dns -d 'ccvitaal.nl,*.ccvitaal.nl'

It produced this output:
Please deploy a DNS TXT record under the name
_acme-challenge.ccvitaal.nl with the following value:

mo8efpFyr2YZIJpyRfc5KCDPd1rkch9cWXTzVa2In8g

Before continuing, verify the record is deployed.

And

Please deploy a DNS TXT record under the name
_acme-challenge.ccvitaal.nl with the following value:

3-y7e0gUDEF2M85ILW2qxyLfJkrbxRgki6oFqr0DTBs

Before continuing, verify the record is deployed.

I added these values at my hosting provider

    Subdomain:@

Type:TXT
TTL:617
Address:_acme-challenge.ccvitaal.nl=mo8efpFyr2YZIJpyRfc5KCDPd1rkch9cWXTzVa2In8g

And

Subdomain:@
Type:TXT
TTL:617
Address:_acme-challenge.ccvitaal.nl=y7e0gUDEF2M85ILW2qxyLfJkrbxRgki6oFqr0DTBs

If I check my settings at unboundtext.com I receive positive results
;; ANSWER SECTION:
Ccvitaal.nl. 1000 IN TXT “_acme-challenge.ccvitaal.nl=mo8efpFyr2YZIJpyRfc5KCDPd1rkch9cWXTzVa2In8g”
Ccvitaal.nl. 1000 IN TXT “_acme-challenge.ccvitaal.nl=y7e0gUDEF2M85ILW2qxyLfJkrbxRgki6oFqr0DTBs”

But I receive an error in my terminal:

Waiting for verification…
Cleaning up challenges
Failed authorization procedure. ccvitaal.nl (dns-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.ccvitaal.nl

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: ccvitaal.nl
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.ccvitaal.nl

I hope someone can help me out.

Kr

My web server is (include version):
Server version: Apache/2.4.18 (Ubuntu)
Server built: 2018-06-07T19:43:03

The operating system my web server runs on is (include version):
Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial

My hosting provider, if applicable, is:
Transit VPS and domain at argeweb.nl
I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no


#2

That’s not how it works.

It should resemble something like:

_acme-challenge.ccvitaal.nl.	1000	IN	TXT	“mo8efpFyr2YZIJpyRfc5KCDPd1rkch9cWXTzVa2In8g”

At your hosting provider, you should specify _acme-challenge as the “subdomain” and just the strange looking value with all the numbers and letters as value, without any quotes.


#3

Hello ,

Thx for Your swift reply.
I forgot to mention that I tried this as well.
But I just ran the command again and changed the settings.

So I changed the DNS settings. E.g.

Subdomain: _acme-challenge.ccvitaal.nl
TXT
Address:glTMop6r8C8IUzeXqCm6qQq

But unfortunately the same error.

Failed authorization procedure. ccvitaal.nl (dns-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.ccvitaal.nl

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: ccvitaal.nl
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.ccvitaal.nl

Any ideas left? I hope you see my error.

Kr


#4

Hi @esorone,

You are not adding the txt records correctly, you are adding those txt records to subdomain _acme-challenge.ccvitaal.nl but you should add them to subdomain _acme-challenge.

Using below command should give you the last added txt records:

dig _acme-challenge.ccvitaal.nl txt

Right now to see your txt records you need to issue this command:

$ dig  _acme-challenge.ccvitaal.nl.ccvitaal.nl txt +short
"glTMop6r8C8IUzeXqCm6qQq_tCE1_su2qFqO_nkOo8s"
"mo8efpFyr2YZIJpyRfc5KCDPd1rkch9cWXTzVa2In8g"

Cheers,
sahsanu


#5

Hello Sahsanu,

Thx, this was indeed the solution.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.