DNS problem: NXDOMAIN looking up TXT


#1

My domain is:

mattshi.com

I ran this command:

certbot certonly -d *.mattish.com --manual --preferred-challenges dns --server https://acme-v02.api.letsencrypt.org/directory

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator manual, Installer None
Obtaining a new certificate
Performing the following challenges:
dns-01 challenge for mattish.com


NOTE: The IP of this machine will be publicly logged as having requested this
certificate. If you’re running certbot in manual mode on a machine that is not
your server, please ensure you’re okay with that.

Are you OK with your IP being logged?


(Y)es/(N)o: y


Please deploy a DNS TXT record under the name
_acme-challenge.mattish.com with the following value:

TiD-QTgoQKTQ1OXHhhUvzSmO_sOmq2OSLIEboldK19g

Before continuing, verify the record is deployed.


Press Enter to Continue
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. mattish.com (dns-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.mattish.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: mattish.com
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.mattish.com

My web server is (include version): Nginx

The operating system my web server runs on is (include version): Debian 9

My hosting provider, if applicable, is: Godaddy

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):0.28.0

I have added a TXT record and run :

dig -t TXT _acme-challenge.mattshi.com

output:

; <<>> DiG 9.10.3-P4-Debian <<>> -t TXT _acme-challenge.mattshi.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10703
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;_acme-challenge.mattshi.com. IN TXT

;; ANSWER SECTION:
_acme-challenge.mattshi.com. 3599 IN TXT “TiD-QTgoQKTQ1OXHhhUvzSmO_sOmq2OSLIEboldK19g”

;; Query time: 65 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Mon Jan 21 06:55:24 EST 2019
;; MSG SIZE rcvd: 112

I think my record is valid.But I still got error.


#2

Hi @SneakyTurt1e

I see, you have already checked your domain via https://check-your-website.server-daten.de/?q=mattshi.com

This looks good.


TXT - Entries

Domainname TXT Entry Status ∑ Queries ∑ Timeout
mattshi.com ok 1 0
www.mattshi.com 1 0
_acme-challenge.mattshi.com oA3rdv-T9WcSGlXBDW5_R4fTMiEYvPqroImxao5uyNU looks good 1 0
_acme-challenge.www.mattshi.com Name Error - The domain name does not exist 1 0
_acme-challenge.mattshi.com.mattshi.com Name Error - The domain name does not exist 1 0
_acme-challenge.www.mattshi.com.www.mattshi.com Name Error - The domain name does not exist 1 0

But therre

you are checking mattish.com without an i. There is no txt entry defined.

So it looks like a typo.


#3

Thank you very much for your help, I made a very stupid mistake :rofl:. Please close it.


#4

Typos happens. And typos are first always invisible.

I know that! :wink:


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.