Certbot not finding acme challenge. DNS TXT seems OKm

#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: baffleplates.com

I ran this command: sudo certbot certonly --manual --preferred-challenges dns

It produced this output:QTb8m-maSA_4sDwg36_pM1g55qDr6_fEqErPSM0PQ9E

Before continuing, verify the record is deployed.


Press Enter to Continue
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. baffleplates.com (dns-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.baffleplates.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: baffleplates.com
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.baffleplates.com

My web server is (include version): N/A doing it manually

The operating system my web server runs on is (include version):Debian 9 Linux d1 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3.1 (2019-02-19) x86_64 GNU/Linux

My hosting provider, if applicable, is: DNS hosted by godaddy; site hosted on my home PC

I can login to a root shell on my machine (yes or no, or I don’t know):Y

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.28.0

#2

You probably needed to wait longer after setting the record.

#3

I set the TTL to 1/2 hour (the minimum on godaddy DNS management) and waited for more than that before hitting return.

I put some screenshots on the web

mips-erp.com/DNS/DNS.png

mips-erp.com/DNS/MoreDNS.png which shows text hidden on the previous png

mips-erp.com/DNS/certbot.png

#4

TTL doesn’t affect the way Let’s Encrypt looks up records.

I don’t doubt you setup the record the right way, but the only explanation seems to be that GoDaddy took a long time to apply the updates to the nameservers.

Let’s Encrypt can see it now:

  Domain: baffleplates.com
  Type:   unauthorized
  Detail: Incorrect TXT record
  "Ql66D0mB8Bd_hBDcRIuXNlv9ew0TZwt_n4Vkt7EQn6Q" found at
  _acme-challenge.baffleplates.com
2 Likes
#5

Thanks. It has now worked.

It would be useful if certbot output was timestamped.

I have put the correct godaddy DNS image on the Net. mips-erp.com/DNS/DNS2.png

I was confused because I missed the point that “Please deploy a DNS TXT record under the name
_acme-challenge.baffleplates.com” meant named “_acme-challenge” in the DNS record for my domain. Maybe the documentation could make this clear.

Thanks for your help

1 Like
closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.