Detail: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.deep-find.com

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: deep-find.com www.deep-find.com

I ran this command:
certbot certonly --manual --preferred-challenges dns --server https://acme-v02.api.letsencrypt.org/directory -d deep-find.com

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator manual, Installer None
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
dns-01 challenge for deep-find.com


NOTE: The IP of this machine will be publicly logged as having requested this
certificate. If you’re running certbot in manual mode on a machine that is not
your server, please ensure you’re okay with that.
Are you OK with your IP being logged?


(Y)es/(N)o: Y


Please deploy a DNS TXT record under the name
_acme-challenge.deep-find.com with the following value:
0Zz9Fgw0dQ4PEri7S_BJ-nha1opl-mskMpnpxtw1hqs
Before continuing, verify the record is deployed.


Press Enter to Continue
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. deep-find.com (dns-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.deep-find.com

IMPORTANT NOTES:

  • The following errors were reported by the server:
    Domain: deep-find.com
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.deep-find.com

My web server is (include version): nginx/1.10.3 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 16.04.5 LTS

My hosting provider, if applicable, is: google domains

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

I’m already checked records of my domain.
Also I waited full time to verify the record is deployed :frowning:

Hi,

Did you remove that record after challenge failure?
I can’t really find that record via dig or nslookup or anything similiar.

Also, how long did you wait before you proceed with the validation?

Thank you

How did you check?
The check I ran returned "empty".
nslookup -q=txt _acme-challenge.deep-find.com

No, I did not remove the record.
I waited about 5 minutes.

In my google domain services.
Is there any other ways to check the acme-challenge records?

Is that record still present?
Since we really can't find it.

You could use something like https://www.whatsmydns.net/ , https://unboundtest.com/ or Network Tools: DNS,IP,Email to check your TXT records.

Thank you

Also, can you confirm that you've added the TXT record onto _acme-challenge.deep-find.com?

Thank you

1 Like

Can see it this time …

$ dig +noall +answer _acme-challenge.deep-find.com txt
_acme-challenge.deep-find.com. 3599 IN  TXT     "sreuDEwLay1oB14AcGrWb_ZsmGq088oQ7TOwQTEJ7B8"
1 Like

OMG. I’ve wrote wrong record name!
Thanks for help to find errors.

1 Like

aww…
Congrats

 

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.