Nightmares with Plesk Windows


#1

Please fill out the fields below so we can help you better.

My domain is: www.horwichadvertiser.co.uk

I ran this command: Renew

It produced this output: Success

My operating system is (include version): Windows Server 2012 R2

My web server is (include version): IIS 8

My hosting provider, if applicable, is: Fasthosts

I can login to a root shell on my machine (yes or no, or I don’t know): No

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes Plesk Onyx 17.0.17

Having nightmares with this. Auto renew doesn’t work, looking in the scheduled tasks it’s greyed out so I can’t see the command to test it so I have to manually renew which is a slow drawn out process. During figuring out how to renew I issued too many certificates and was blocked for a week taking the web and app services down for the above domain. Documentation for Windows & the Plesk extension seem limited.

The problem appears to be the certificate only working for https://horwichadvertiser.co.uk although I did tick Include www.horwichadvertiser.co.uk as an alternative domain name.


#2

hi @ScottC

Looks like you are passing the challenges as you have had quite a few certs issued

https://crt.sh/?q=horwichadvertiser.co.uk+

now the challenge is where are they and how to get them in to windows.

the challenge with plesk plugin is that i think it’s a two component. A python script that does the backend work and a PHP integration for Plesk.

As the PHP integration is obfuscated it’s hard to troubleshoot errors.

https://github.com/plesk/letsencrypt-plesk/blob/master/CHANGES.md

Andrei


#3

you also have certs for https://crt.sh/?q=www.horwichadvertiser.co.uk+

https://www.plesk.com/blog/lets-encrypt-plesk/ confirms the python client + php front end theory

it also appears you have resolved the issues?


#4

Thanks for the replies. I had, just before making this post reissued the certificate after the 7 day block and it hadn’t worked. It must take a while for the settings to change or something.


#5

you are right the 7 day block would have cleared today

the certificate you are currently using is correctly issued as a SAN certificate

all i can think of is that there was confusion around the website configs which caused multiple certificates to be issued

I had a look at the python code and it’s using Plesk APIs to retrieve the certificates and then install them into plesk directly

The certificates are not retained on on file system from what i can see.

The challenge could have been with API calls. Trying to find if there is a log somewhere.

It is possible that API call failures are not gracefully handled (i.e. stop trying) or there is a scheduler interfering.

more sleuthing to do :smiley:


#6

Thanks, those must be the ones I issued manually. They’ve never updated automatically. There is a task set up in Scheduled Tasks running the PHP file renew-certificates.php that’s to run on 15th of every month. This was automatically set up when installing the module via the Plesk interface. I can’t edit or change it and the PHP file is encrypted so I can’t debug from that point.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.