Cert not renewing in Plesk (auto or manual)

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: stevendtaylor.com

I ran this command: n/a

It produced this output: n/a

My web server is (include version): DV w/SSDs (CentOS 6) - Level 1 (mt) media temple

The operating system my web server runs on is (include version): CentOS 6.5 (Final)‬

My hosting provider, if applicable, is: (mt) media temple

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk version 12.5.30 Update #79, last updated at Jan 15, 2019 12:38 AM

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): IDK

Hello,

I’ve installed a Let’s Encrypt cert for https://stevendtaylor.com/ inside (mt) media temple / Plesk however, it’s not renewing automatically. I also tried to manually renew the cert inside Plesk today but that didn’t work either. I was assuming that the cert would auto extend past April 3rd, 2019. Can you help me fix this please? I waited for auto renew, that didn’t work. Then I tried a manual renew, and this didn’t work either.

Please advise very soon. Thank you.

  • Steven T.

Hi @sdtaylor0761

are there some error messages? Did you ask your hoster?

Plesk is a “closed system”, so it should work.

But: Checking your domain perhaps there is a problem (via https://check-your-website.server-daten.de/?q=stevendtaylor.com ):

Domainname Http-Status redirect Sec. G
http://stevendtaylor.com/
192.124.249.10 301 https://stevendtaylor.com/ 2.994 A
http://www.stevendtaylor.com/
192.124.249.10 301 http://stevendtaylor.com/ 0.250 D
https://www.stevendtaylor.com/
192.124.249.10 301 https://stevendtaylor.com/ 5.607 B
https://stevendtaylor.com/
192.124.249.10 200 7.167 B
http://www.stevendtaylor.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
192.124.249.10 301 http://stevendtaylor.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 0.410 D
Visible Content: 301 Moved Permanently nginx
http://stevendtaylor.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
192.124.249.10 503 0.764 S
Service Unavailable
Visible Content: Steven D. Taylor – Photographic Artist – Nature Lover Check Back Later ! Website will be available soon © StevenDTaylor.com 2006-2018

There is a

Server: Sucuri/Cloudproxy

But the last check - http + non-www + /.well-known/acme-challenge - there is a http status 503.

So it may be impossible that Letsencryt validates your domain name.

Why is there a 503? A http status 404 - Not Found - is expected.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.