Invalid Key Specified!

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): webuzo

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

My certificate expired and after auto renew doesn't work, ( Invalid Key Specified!)
I have revoke on my other website, and reinstaled the certificate but I got the same error: Invalid Key Specified!

can someone help please!

thank you

1 Like

Please edit your first post and actually answer all the questions, even if it's "I don't know."

Also please provide the entire output, i.e. with context.

And note that revoking your certificate(s) is almost never required.

Did you also by any chance perhaps mean instead of the current

And yet another thing: I see you've gotten ZERO certificates from Let's Encrypt in the past: All your recent certificates are from ZeroSSL, which is a different CA than Let's Encrypt. Please take your issue up with their support.

And last thing: it seems you have gotten two certificates from ZeroSSL (see link above) two days ago (and some more some days before that). So you have many valid certificates already.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.