Registered Let's enscrypt, but invalid certificate. Please HELP!

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: I tried to access my website as] in various browsers but can't

It produced this output:

My web server is (include version): Apache 2.4

The operating system my web server runs on is (include version): Centos 7

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): I'm using DirectAdmin

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I'm using plugin Let's encrypt of Directadmin

Do you need to restart apache? It's still serving your self-signed (default) certificate, not the Let's Encrypt cert.

Re-check all of the configuration you've done: SSLs and Let's Encrypt For Domains | Directadmin Docs


Thank you very much for your prompt reply. Let me try, then I will share the result

1 Like

Did you already get a new certificate? Because I can only see a single certificate from 2018 issued:

1 Like

Not yet, My issues is still not fixed. I'm waiting for more detailed advice from community. Thanks all for your help!

1 Like

I'm a little bit puzzled about what kind of "detailed advice" you expect from us to be honest. Your thread is about the fact your webserver still serves a self signed certificate. But that's to be expected if there hasn't been any Let's Encrypt certificate issued at all. It seems your DirectAdmin Let's Encrypt plugin hasn't worked at all, but without any details about that process, it's impossible to assist you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.