Http verification getting failed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: josfolio.com

I ran this command: I used zerossl for http verification but as soon as I click the link in zerossl, after saving in the root in acne.challenge folder , instead of returning the key to us it displayed a 404error. Note, I haven’t designed my website, it is still under construction. Any help pls?

It produced this output: 404 error

My web server is (include version): Apache

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): uses cPanel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @Josfolio

if you use cPanel, first you should check if there is an integrated solution you can use.

Your main config looks ok ( https://check-your-website.server-daten.de/?q=josfolio.com ):

Domainname Http-Status redirect Sec. G
http://www.josfolio.com/
107.180.28.183 301 http://josfolio.com/ 0.800 D
http://josfolio.com/
107.180.28.183 200 1.167 H
https://www.josfolio.com/
107.180.28.183 301 https://josfolio.com/ 1.777 N
Certificate error: RemoteCertificateChainErrors
https://josfolio.com/
107.180.28.183 200 2.243 N
Certificate error: RemoteCertificateChainErrors
http://www.josfolio.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
107.180.28.183 301 http://josfolio.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 0.933 D
Visible Content:
http://josfolio.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
107.180.28.183 404 1.250 A
Not Found

Checking a file in /.well-known/acme-challenge there is the expected answer http status 404 - Not Found.

So first step: Create the two subdirectories

YourDocumentRoot/.well-known/acme-challenge

there a file (file name 1234), then try to load that file via

http://www.josfolio.com/.well-known/acme-challenge/1234

That must work. If not, you have used the wrong DocumentRoot or you have additional definitions.

as you have mentioned i have recreated the subdiretories and saved the file to…
/home/gqjpwd5kpitu/public_html/.well-known/acme-challenge
and have tried to load the file but not much different than earlier.
the documentroot is public_html as far as i know…

1 Like

Then it’s the wrong webroot. Or you have additional location definitions.

Or cPanel blocks /.well-known or comes with own location definitions.

any way to solve it…the right webroot?.how to solve or find the additional location definitions?

1 Like

Ask your hoster. It may be impossible because of your configuration.

But if you use zerossl, you use a manual solution.

So you can use dns-01 validation -> create a TXT entry. That should always work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.