ZeroSSL HTTP verification fails


#1

My domain is: chantage.info

I ran this command:
C:\le64\le64.exe --key tolgainci.key --csr chantage.info.
csr --csr-key chantage.info.key --crt chantage.info.crt --domains “www.chantage.
info,chantage.info” --path C:\xampp2\htdocs\joomla35.well-known\acme-challenge
–generate-missing --unlink

It produced this output:
2018/12/09 18:49:41 [ ZeroSSL Crypt::LE client v0.32 started. ]
2018/12/09 18:49:41 Loading an account key from tolgainci.key
2018/12/09 18:49:41 Loading a CSR from chantage.info.csr
2018/12/09 18:49:42 Registering the account key
2018/12/09 18:49:43 The key is already registered. ID: 7539790
2018/12/09 18:49:43 Successfully saved a challenge file ‘C:\xampp2\htdocs\joomla
35.well-known\acme-challenge/5pVpnnZyFNlNNoUjtXmaPJwHjrD54XjpuY9LQLGw5ZI’ for
domain ‘www.chantage.info’
2018/12/09 18:49:43 Successfully saved a challenge file ‘C:\xampp2\htdocs\joomla
35.well-known\acme-challenge/Tin_g9iJnLemBQQb4uK2Vrjw6SF8o3Xit8iK7hHWw8Y’ for
domain ‘chantage.info’
2018/12/09 18:49:46 Domain verification results for ‘www.chantage.info’: error.
Fetching https://www.chantage.info.well-known/acme-challenge/5pVpnnZyFNlNNoUjtXm
aPJwHjrD54XjpuY9LQLGw5ZI: Error getting validation data
2018/12/09 18:49:46 Challenge file ‘C:\xampp2\htdocs\joomla35.well-known\acme-c
hallenge/5pVpnnZyFNlNNoUjtXmaPJwHjrD54XjpuY9LQLGw5ZI’ has been deleted.
2018/12/09 18:49:48 Domain verification results for ‘chantage.info’: error. Fetc
hing https://www.chantage.info.well-known/acme-challenge/Tin_g9iJnLemBQQb4uK2Vrj
w6SF8o3Xit8iK7hHWw8Y: Error getting validation data
2018/12/09 18:49:48 Challenge file ‘C:\xampp2\htdocs\joomla35.well-known\acme-c
hallenge/Tin_g9iJnLemBQQb4uK2Vrjw6SF8o3Xit8iK7hHWw8Y’ has been deleted.
2018/12/09 18:49:48 All verifications failed

My web server is (include version): Apache 2.4

The operating system my web server runs on is (include version): Windows Server 2008 R2 SP1

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

Hello,

I’m trying to automate my certificates using do-know/Crypt-LE tool from zerossl.com. The tool tries to verify with address https://www.chantage.info.well-known/acme-challenge/ which misses a / in between the domain name and .well-known, and of course fails. When I upload a file in the same directory, and use the correct URL I can reach it without problems. Any ideas how I can fix this error?

Best Regards,

Tolga


#2

Hi @tolgainci

checking your domain with my online tool ( https://check-your-website.server-daten.de/?q=chantage.info ):



You see the problem.

Letsencrypt starts with loading your validation file via http, then there is a redirect to https.

But this redirect doesn’t add a / after the domain name.

So the result is https://www.chantage.info.well-known/ as domain name.

This is wrong - so the validation fails.

Fix your redirect http -> https.


#3

Thank you so much! The problem is solved after I fixed the redirect on Apache server. For anyone having the same problem, here are the details:

Changed the following line in my httpd-vhosts.conf:

Redirect / https://www.chantage.info

To:
Redirect “/” “https://www.chantage.info/

Restarted Apache and done :slight_smile:


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.