Error installing certificate help me if you milk

Je peux lire des réponses en Anglais :

J’ai exécuté cette commande :
sudo yum-config-manager --enable epel
wget https://dl.eff.org/certbot-auto
chmod a+x certbot-auto
sudo ./certbot-auto --debug

Elle a produit cette sortie :
I get this error when I try to install letsencrypt with cerbot



Help me please.
I am on AMAZON Linux AMI.
Thank you

Mon serveur Web est (inclure la version) :
Amazon Linux AMI release 2018.03
Apache72

Mon hébergeur, le cas échéant, est : AWS

Je peux me connecter à un shell root sur ma machine (oui ou non, ou je ne sais pas) :
OUI
Thank you

1 Like

Hi @blasy,

I’m afraid you wrote “s’il vous lait” :milk_glass: instead of “s’il vous plait” in machine translation. I don’t drink milk, but I hope I can help you. :grinning:

The error at the very end says that you need to have a virtual host configured in Apache, with the HTTP (port 80) version of the site that you want to secure. This is a requirement for using certbot --apache. That is, your site must already be working in HTTP before you try to use Certbot to make it work in HTTPS.

https://httpd.apache.org/docs/current/fr/vhosts/
https://httpd.apache.org/docs/current/fr/vhosts/name-based.html

Normally these would be created in individual files in /etc/apache2/sites-available and then enabled with the a2ensite command.

Once your site is working with HTTP using this configuration approach, Certbot will understand how to make it work in HTTPS too.

2 Likes

I was starting at this title for so long trying to figure out what they meant. je peux parler un peu de français, mais c’est déroutant. This is the best thing I’ve read all month, thank you both!

1 Like