Cerbot unauthorized error


#1

Please help this is my first try using letsencrypt.

My domain is: demo.ihsfullerton.co.id

I ran this command: certbot --apache

It produced this output: i copied the output to a file, please look at the bottom of this post

My web server is (include version): Apache/2.4.18 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 16.04.4 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

my letsencrypt.log


#2

Hi

Your log file seems to be cut off.

Can you check if that’s all logs you have (for this operation?)

Thank you

Also,
What is the exact error message?


#3

Hi

Sorry the log was chopped. I have updated the file in the link. Please have a look again.

The error message is the acme challenge returned 404.

Thank you,


#4

Hi,

I don’t really know the issue. But it might be the fact that your apache vHost hasn’t been properly set up yet. (Returns default vHost Page when visited) (since you are using certbot --apache)

Can you use this link to set it up first:

Thank you


#5

@bmw @joohoi, this is a failure with --apache on 0.22.2 where the Certbot-created virtual host didn’t appear to take effect for the requested challenge path. Any thoughts?


#6

Hi

I disabled by virtual hosts and the certbot finished successfully. This is non issue.

Thank you for the responses


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.