Getting a no installers error message on amazon linux


#1

While trying to use this I keep running into an issue. If it’s something I’m missing, I apologize ahead of time as I’m been doing linux/cli/amazon/ssl for less than a year now. I was able to get the LE client to install and able to run certonly --standalone to get a good cert at least on the machine.

I then tried to use install to install that cert but I then get a message stating that no installers are available on your OS yet; try running letsencrypt-auto certonly to get a cert. I’ve already done that and have specified the cert/key paths when running the install.

Can anyone offer some advice?

Thanks in advance for your time.


#2

Please provide the exact command you used when you got that error message.


#3

I’m not clear on where your issue is …

You say that you have used “certonly --standalone to get a good cert”. So I assume you have obtained the certificate successfully.

You then say “tried to use install to install the cert”. How are you trying to “install” it ?


#4

pfg - ./letsencrypt-auto install --cert-path --key-path

serverco - I did obtain the certificate successfully. It’s in /etc/letsencrypt. Am I misunderstanding that part of LE is also installing/configuring the cert as well? I tried to install it using the above command I referenced to pfg.

Thank both of you for your quick response.


#5

Automatic installation is currently only available for apache2 on debian-based distributions. Amazon Linux is based on CentOS iirc. Additionally, I don’t think letsencrypt-auto install is a valid invocation of the client. To use the apache plugin, you would simply pass --apache to the client (but that wouldn’t work on your OS anyway).

You will have to perform the installation manually. Maybe the Mozilla SSL configuration generator will help you. If you’re using apache, you would need something like this in your vhost to get apache to use your Let’s Encrypt certs (this is not a complete configuration, refer to the generator):

SSLCertificateFile /etc/letsencrypt/live/example.com/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/example.com/privkey.pem

#6

it’s probably worth reading the documentation

You originally used a “certonly” which effectively gets the certificate but doesn’t try and install it. If you use that method then as far as I’m aware there isn’t a way to get it the LE script automatically install it into the right place for you.

Are you using Apache ? and are you using any “control panel” or other system to manage apache ? or just the core apache ? If you have a “control panel” it will probably have a system for installing the SSL cert. If not, then you need to add it manually (relatively straightforward, simply editing a text file )


#7

Thanks for the replies again, I really appreciate it. I was able to get it installed manually, I was just wanting to make sure that I hadn’t missed something in the way of an automatic installation possibility and renewing every 90 on this particular machine probably isn’t going to happen from what I’m told.

Thank you both once again for your time and assistance.