No installers seem to be present and working on your system


#1

I got an error just after executing
./letsencrypt-auto --agree-dev-preview --server
https://acme-v01.api.letsencrypt.org/directory

Error message:
No installers seem to be present and working on your system; fix that or try running letsencrypt with the “auth” command
Does anyone know how to solve it?


#2

Hi @Xtr. In the context of Let’s Encrypt, an installer is a plugin that can take a certificate and automatically configure a webserver to use it. For example, we have an Apache installer that is able to automatically install certificates for Apache 2.x on Debian based systems. Currently, this is our only working installer.

You saw this error message because Let’s Encrypt couldn’t find an installer applicable to your system (you’re not running Apache on Debian). The default behavior of Let’s Encrypt is to both obtain a certificate from the ACME server and configure it to work with the software on your server. The auth command, however, obtains the certificate from the server but does not install it. If you’re not running Apache on Debian, this is the behavior you want so simply append “auth” to the command line you posted above.

For additional help, you can run letsencrypt --help.


#3

Hi @bmw
Thanks for the information.

Yes I am using Nginx on Debian.
So I need to manually configure the Nginx server.
Set the certificates path and key path to those generated files by letsencrypt auth in nginx configuration file.

After I finished this stuff. According to https://helloworld.letsencrypt.org/ I should not see any error when accessing my website in browser. But I still saw the certificate is issued by happy hacker fake CA and got the warning from Chrome.

Am I missing something?


#4

“happy hacker fake CA” is the issuer used in our staging/testing server. This is what the Let’s Encrypt client currently uses when you don’t specify a different server using the --server option like you did in the original post. Because of this, I believe the --server flag was not included when you ran the client. Try running the client again, but make sure you include the --server option from your original post.


#5

Thanks!

–server flag makes it to 'Let’s Encrypt Authority X1’
But the ssllabs report is still saying not trusted. Anything else I need to pay attention?

Update:
After adding cert chain, it works well!


#6

Congratulations! Glad you got it working.


#7

@Xtr, I’m sorry that the Nginx plugin is currently not working. We do have a plugin for Nginx which has been working in the past, but currently, as you saw, it’s not quite ready to be used on live systems.

Hopefully the Nginx plugin will be updated and available in good working order soon, since we know that lots of people would like to use it. Anyone reading this with Python development experience is welcome to contribute to the project.

As you saw, it is possible to obtain certificates in another way and then configure them in Nginx, but we would certainly like to make the experience much more automatic and seamless. I’m glad you were able to get things working properly on your system, and thanks for helping us test the service.

One practical issue is that, without more complete integration, automated renewals won’t happen when your certificate expires. So bear in mind that you’ll need to get a new certificate when this one expires, presumably currently 90 days from now.


#8

Hello,

The command ./letsencrypt-auto works for me only without the --server flag. However, as mentioned on this thread, this gives a certificate signed by Happy Hacker Fake CA

However, when I run it with the --server flag, I get an error: Error: unauthorized :: The client lacks sufficient authorization :: Error creating new authz :: Name is not whitelisted

My question is how to get rid of this error or get the domain name whitelisted ?

Thanks a lot for your suggestions.


#9

Currently only close beta users’ domains are in whitelist.

You can apply to the beta test here.