[Please Help] 'No installers present' with apache2 on Raspbian


#1

So i was trying to ./letsencrypt-auto but it gives

Checking for new version... Requesting root privileges to run letsencrypt... /root/.local/share/letsencrypt/bin/letsencrypt No installers seem to be present and working on your system; fix that or try run ning letsencrypt with the "certonly" command

I am definitely running apache2 on the pi

and if i run ./letsencrypt-auto --apache
it gives
The apache plugin is not working; there may be problems with your existing configuration. The error was: NotSupportedError('Apache plugin support requires libaugeas0 and augeas-lenses version 1.2.0 or higher, please make sure you have you have those installed.',)

I am very new to these kinds of things so please bear with me if I am doing something stupid.

Any help would be greatly appreciated!


#2

give us at least the distribution/os and version
so we can have a hope of guessing the issue

though im guessing some form of debian on rasbery pi from subject
also the version of apache would be good (to see if it even has the letsencrypt modules available)


#3

Sorry about that, here’s the information:
Raspbian GNU/Linux 7 (wheezy) Apache/2.2.22 (Debian)

I don’t know whether this is of any use but:
apache2ctl -M /usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted) apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName Loaded Modules: core_module (static) log_config_module (static) logio_module (static) version_module (static) mpm_prefork_module (static) http_module (static) so_module (static) alias_module (shared) auth_basic_module (shared) authn_file_module (shared) authz_default_module (shared) authz_groupfile_module (shared) authz_host_module (shared) authz_user_module (shared) autoindex_module (shared) cgi_module (shared) deflate_module (shared) dir_module (shared) env_module (shared) mime_module (shared) negotiation_module (shared) php5_module (shared) reqtimeout_module (shared) setenvif_module (shared) status_module (shared)


#4

well simply put according to the documentation the apache plugin isnt available in 2.2 of apache
https://letsencrypt.readthedocs.org/en/latest/using.html#plugins


#5

i use 2.2 on several of my older mirrors and simply have a global alias of /.well-known/acme-challenge/ to a local directory were the webroot plugin deposits the challenges
i test by putting a single file test.txt there and manually browsing to it via each sitename first
then run the client specify 1 webroot and all the hosted domain names and done


#6

Oh… I see thank you very much for you help. I just assumed that using apt-get update and install apache2 would give me the newest version.

I’ll migrate to 2.4 and see if the problem persists.


#7

What is not clear about the error message “Apache plugin support requires libaugeas0 and augeas-lenses version 1.2.0 or higher, please make sure you have you have those installed”?

https://packages.debian.org/wheezy/libaugeas0


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.