DNS problem: NXDOMAIN looking up A for www.falafeels.hero-translating.com

Dear fellow Let’s Encrypt users,
Could you please help me with the error I am getting? I’ve checked the log in /etc/letsencrypt and it ends with the following error message:

    Domain: www.falafeels.hero-translating.com
    Type:   connection
    Detail: DNS problem: NXDOMAIN looking up A for www.falafeels.hero-translating.com

What should I change in my setup, so that the cert could be acquired? In my DNS setup - falafeels.hero-translating.com has an A record pointing to 95.80.200.32.

Hi @kalandarisvili,

falafeels.hero-translating.com has an A record pointing to 95.80.200.32 but www.falafeels.hero-translating.com doesn't have an A record. You should add it in your DNS Server... the same you did for falafeels.hero-translating.com but this time for www.falafeels.hero-translating.com.

Cheers,
sahsanu

1 Like

Hello @sahsanu,
Problem is I cannot have www.falafeels in the Hostname portion of my DNS console, because it says incorrect value.

Then you should ask to your DNS provider because if you can't add www.falafeels to the host name field seems a bug in that web control panel.

Is there an option to add a subdomain?

@rg305 There is an option to add a subdomain. Main domain is hero-translating.com, falafeels.hero-translating.com is a subdomain.

You could also add a CNAME: www.falafeels -> falafeels.
Maybe this works.

In this case @rg305 meant adding a subdomain of the subdomain. If you can only add one level of subdomain, that’s a limitation in the interface.

By the way, if you can’t add the A record here, the www form would not work in a browser anyway even via unencrypted HTTP (regardless of the issuance of the certificate).

So @sahsanu’s advice makes sense: you can ask the DNS provider, or whoever created this form. If the form really only allows you to add a single level of subdomain, it’s not adequate for doing what you want to do here.

One thing to try first could be to enter www.falafeels in the box as new the name to add. It might be a little confusing, but perhaps this form already allows you to add a subdomain of a subdomain that way. There’s no way to predict this without trying it. :slight_smile:

I hate to disagree with you, but as shown by your picture,
falafeels.hero-translating.com” is just an A record in the domain "hero-translating.com"
There are no subdomains shown.
if the menu doesn’t have an option to create a subdomain, then you are stuck with just
"wordsANDnumbers.hero-translating.com"
but no subdomain(s) - like: www.whatever.hero-translating.com

You might try adding a “catch all” CNAME (like “*” or “@”). and send that to “falafeels.hero-translating.com”.

It is a subdomain of hero-translating.com. However, the host still needs to allow creating a subdomain of a subdomain here, which it’s still not clear if they do or not.

@schoen @rg305 @sahsanu @bytecamp @honzakuchar
Thank you all for your suggestions. I have contacted the provider and will let you know how it develops once I have their response!

1 Like

@schoen @rg305 @sahsanu @bytecamp @honzakuchar
Provider has added www.falafeels record as another A name:
www.falafeels.hero-translating.com 1800 A 95.80.200.32,
which has allowed me to re-run ./certbot-auto --apache. It works now.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.