[Solved] I can't install Let's Encrypt Certificate in my subdomain. (Show me error message)


#1

Morning, hi all… I am @Tavo, from Chile.

I have problems with the Let’s Encrypt SSL installation.
My situation:
Hosting provider: Banahosting (www.banahosting.com)
CDN: CloudFlare (free plan)

I have a main domain: adopslatam.cl. This domain is OK with the Let’s Encryot certificate (It is working)
I have many subdomains:

mega.adopslatam.cl => In this subdomain, Let’s Encrypt certificate is ok.

ads.adopslatam.cl => In this subdomain, I can’t install certificate.
yapo.adopslatam.cl => In this subdomain, I can’t install certificate.

When I try to install (using the cpanel option) appears this message:

" There was a problem processing your request

My domain is: adopslatam.cl

I ran this command: I am using the cpanel option to install.

It produced this output:
"There was a problem processing your request

My web server is (include version):Apache Version 2.4.34

The operating system my web server runs on is (include version): linux . (Kernel Version 3.10.0-714.10.2.lve1.5.15.el7.x86_64)

My hosting provider, if applicable, is: Banahosting

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes, I am using cpanel 74.0 (build 8)

I hope your help.

Thanks a lot, from Chile (the last corner of the world)

Tavo


#2

Either create the A record for www.yapo.adopslatam.cl on Cloudflare, or uncheck the www checkbox in the Let’s Encrypt interface when you’re issuing the certificate.


#3

Hi @Tavo

if you use cPanel to create a certificate (which is the best solution if you use cPanel), then normally cPanel creates one certificate with two domain names - the www and the non-www version of your domain.

But:

nslookup yapo.adopslatam.cl.
Name: yapo.adopslatam.cl
Addresses: 2606:4700:30::681b:9eb9
2606:4700:30::681b:9fb9
104.27.158.185
104.27.159.185

D:\temp>nslookup www.yapo.adopslatam.cl.

*** www.yapo.adopslatam.cl. wurde von fritz.box nicht gefunden: Non-existent domain.

Your non-www exists. Your www doesn’t exist.

So add www.yapo.adopslatam.cl as CNAME -> yapo.adopslatam.cl


#4

THANKS A LOT!!!

I did it and all is working now. Perfectly!!!

Best regards

Tavo


#5

THANK YOU VERY VERY MUCH!!
Your councils was very usefull.
Now, all is working perfectly.

Best regards…

Close Case!!!

Tavo


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.