Don't run create certificate for subdomain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My subdomain is: test.gamesyap.com

I ran this command: certbot-auto certonly -d test.gamesyap.com -d www.test.gamesyap.com

It produced this output:
root@ubuntu:/etc/letsencrypt/live# certbot-auto certonly -d test.gamesyap.com -d www.test.gamesyap.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log

How would you like to authenticate with the ACME CA?


1: Nginx Web Server plugin (nginx)
2: Spin up a temporary webserver (standalone)
3: Place files in webroot directory (webroot)


Select the appropriate number [1-3] then [enter] (press ‘c’ to cancel): 1
Plugins selected: Authenticator nginx, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.test.gamesyap.com
Using default address 80 for authentication.
nginx: [warn] conflicting server name “mail.gamesyap.com” on 0.0.0.0:80, ignored
Waiting for verification…
Challenge failed for domain www.test.gamesyap.com
http-01 challenge for www.test.gamesyap.com
Cleaning up challenges
nginx: [warn] conflicting server name “mail.gamesyap.com” on 0.0.0.0:80, ignored
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.test.gamesyap.com
    Type: connection
    Detail: dns :: DNS problem: NXDOMAIN looking up A for
    www.test.gamesyap.com

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): nginx 1.14.0 on ubuntu

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
I am not using control panel
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.28.0

Hi @techcomputerworld

you don’t have such a DNS entry ( https://check-your-website.server-daten.de/?q=test.gamesyap.com ):

Host T IP-Address is auth. ∑ Queries ∑ Timeout
test.gamesyap.com A 139.162.165.192
Frankfurt am Main/Hesse/DE yes 1 0
AAAA yes
www.test.gamesyap.com Name Error yes 1 0

So that can’t work. First create the A entry with your ip address.

2 Likes

Hi @techcomputerworld,

According to the snippet you posted, I believe you’re missing a DNS A record for www.test.gamesyap.com. You can verify this for yourself with the following commands.

$ dig www.test.gamesyap.com +short
2 Likes

Hi, it applies to you to put the www.test on a AAA record as you can see in this image because I certainly do not understand the subject very well.


I’ve put www.test under the whole It’s okay like that

2 Likes

Now your www.test has an ipv4 address ( https://check-your-website.server-daten.de/?q=test.gamesyap.com ):

Host T IP-Address is auth. ∑ Queries ∑ Timeout
test.gamesyap.com A 139.162.165.192
Frankfurt am Main/Hesse/DE yes 1 0
AAAA yes
www.test.gamesyap.com A 139.162.165.192
Frankfurt am Main/Hesse/DE yes 1 0
AAAA yes

So try it again.

1 Like

Hi, the problem is solved by putting www.test as I put it in the picture thank you very much for your help, otherwise I could not fix the problem

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.