Certificate didn't automatically renew?


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: ridgewoodguild.com

I ran this command: didn’t type any commands

It produced this output: website certificate didn’t automatically renew

My web server is (include version): not sure/ don’t have access

The operating system my web server runs on is (include version): not sure/ don’t have access

My hosting provider, if applicable, is: wordpress

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no just wordpress

I took over website maintenance for this website over the summer. I was not involved in the creation of it, so I do not know the ins and outs. I have never had a problem with the SSL automatically renewing since I’ve had control of the website. Then all of the sudden, at the end of this month the certificate expired and has not been renewed.

Is there any way to just renew it? Do i have to prove some type of validity to lets encrypt?


#2

You’ll need to figure out how the certificate was acquired to begin with. There’s a variety of ways to use Let’s Encrypt.

Since you appear to have a an nginx/Linux VPS, perhaps we can start with:

grep -R ssl_certificate /etc/nginx
find /etc/letsencrypt/renewal

If you can’t login to SSH, you need to find someone who can. There’s no way around that.


#3

Hi @shanecurry

your oldest certificate is from 2017-01~~

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=p:cmlkZ2V3b29kZ3VpbGQuY29tOnRydWU6ZmFsc2U6NDQyODYyNDQ5ODAwODg1MzgyNzpFQUU9&cert_search=include_expired:true;include_subdomains:false;domain:ridgewoodguild.com;issuer_uid:4428624498008853827&lu=cert_search_cert

Is there a WordPress-Addin which supports Letsencrypt?


#4

seems to have renewed itself, maybe it was due to my inactivity in managing the site but either way, problem solved