Can't get certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: friendsofipswichmuseums.org.uk

I ran this command: request for certificate

It produced this output: There was a problem processing your request

My web server is (include version): no idea

The operating system my web server runs on is (include version): no idea

My hosting provider, if applicable, is: Krystal

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes - cPanel 84.0.22

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): sorry, I don’t even know what this means

1 Like

There are four IPs for friendsofipswichmuseums.org.uk:

Addresses:  198.185.159.145
          198.49.23.144
          198.49.23.145
          198.185.159.144

Are you using a CDN service or load-balancer?

1 Like

I’d say they do: https://www.ssllabs.com/ssltest/analyze.html?d=www.friendsofipswichmuseums.org.uk&s=198.49.23.145&hideResults=on&latest

@paolo-56: did you read this? https://support.squarespace.com/hc/en-us/articles/205815898-Understanding-SSL-certificates

2 Likes

Thank you both for responding so promptly. My client ‘Friends of Ipswich Museums’ has just engaged me to look into various problems that they have with their setup and so as I write I know very little about it. One of the problems was that they kept getting messages that their SSL certificate was failing to renew. I deleted it and tried to set it up again from scratch, that’s when I got the error that I reported initially. The client tells me that they have moved at some point from Wordpress to Squarespace. Having read the article at the link you kindly provided 9peppe, it seems that SSL certification is integral to Squarespace and so the SSL certificate that they had became redundant. So it looks as though I have done the right thing in deleting it, albeit unknowingly!

1 Like