Auto-renewal issue, one of many fails, from Plesk


#1

I got several domains, and ONE of them fails to autorenew, I suspect it is due to it starting with a digit.
Manual renewal works just fine.

My domain is: 3z81.dk

I ran this command: Selected for autorenewal from within Plesk

It produced this output:
“Information: Let’s Encrypt SSL/TLS certificate has been installed on 3Z81.dk.”

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Yes “Plesk” (can not find a version id - the help is just a generic link)

I got several other domains on the same account that autorenew just fine.
I do get the mails with
"Information: Let’s Encrypt SSL/TLS certificate has been installed on 3Z81.dk. "

Manual renewal works just fine though - but a bit annoying, to do it manually.


#2

Unless something in the Plesk Let’s Encrypt logs illuminates the reason for the failure, you might look to report this directly to Plesk, as I don’t believe any of their developers hang out here and only they could fix this kind of issue.


#3

Thanks for the quick reply.

Is it the Plesk, and not “Let’s encrypt” that do the auto-renewal?

If so, sure the question is put at the wrong forum.


#4

You can think of it as: every 60 days, Plesk connects to Let’s Encrypt and asks for a new (renewed) certificate.

So, if Plesk is failing to ask for a new certificate or is doing it wrong for number-prefixed domains, the issue must be addressed by Plesk. In other words, it’s a bug in Plesk’s integration of Let’s Encrypt.

If Plesk is asking for a new certificate but Let’s Encrypt is failing to provide one, the issue would need to be addressed by Let’s Encrypt.

If you have access to the Plesk logs in the link in my previous post, it could be helpful to figure out which is the case. If you don’t own the Plesk server where your site runs, you might also ask your web host to take a look at the logs for you.


#5

Thanks, I do not have access, but will ask the guys hosting the domain :slight_smile:
And as the manual renew is correct, it could be some simple issues like quotes that are used differently on the attempted auto-renewal. - And hence a plesk-issue.


#6

The hosting provider just answered that he has tried to change the certificate name to be equal to the domain name (and renewed it). So crossing my fingers that it fixes the issue :sunny:

’lets encrypt 3Z81.dk’ to ’3Z81.dk’


#7

Unfortunately that trick did not help… Just got a “Let’s Encrypt certificate expiration notice for …”

I will try to contact the hosting provider again.


#8

You might want to check with ssllabs.com first and see if the certificate you are actually using is really expiring when the e-mail says. It’s possible that your hosting provider had to change your certificate to get it working, and the expiration notice you are receiving refers to the old certificate that refused to renew.


#9

Thanks, that was my first guess too, so after a few more ignored warning mails it expired…
(Luckily it is not an important domain, just some stuff from my old high school class)


#10

BTW, Is there any way you can check if you got ANY other domain starting with a digit that auto-renews correctly before expiration?

I’m still in doubt on whether the bug is with Plesk or LetsEncrypt.

Are there any special enclosing needed in the call for names starting with a digit we should look for? (Quotes, brackets or similar)


#11

This behaviour might well be related to a plesk-issue, that should be fixed soon


As the hosting provider has pointed out.


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.