Virtualmin - Gave up waiting for valiation

Please fill out the fields below so we can help you better.

My domain is: www.domain.com

I ran this command: Request Certificate (within Virtualmin). The Cert has been installed and working - I was attempting to renew it.

It produced this output:

Requesting a certificate for domain.com, www.domain.com, mail.domain.com from Let’s Encrypt …
… request failed : Failed to request certificate :
Parsing account key…
Parsing CSR…
Registering account…
Already registered!
Verifying www.domain.com
Traceback (most recent call last):
File “/usr/libexec/webmin/webmin/acme_tiny.py”, line 235, in
main(sys.argv[1:])
File “/usr/libexec/webmin/webmin/acme_tiny.py”, line 231, in main
signed_crt = get_crt(args.account_key, args.csr, args.acme_dir, args.dns_hook, args.cleanup_hook, log=LOGGER, CA=args.ca)
File “/usr/libexec/webmin/webmin/acme_tiny.py”, line 171, in get_crt
raise ValueError(“Gave up waiting for valiation”)
ValueError: Gave up waiting for valiation

My operating system is (include version): CentOS Linux 6.8

My web server is (include version): Apache 2

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Virtualmin

@diafygi, it looks like Virtualmin is using acme-tiny. Do you have any suggestions here?

Many thanks for your response. I’ve been struggling to find anything on this all day. I can’t find anything like this issue on the virtualmin forum

Virtualmin released a fix for this issue which worked for me. The fix is actually for the webmin module so while I had the current version of virtualmin, webmin needed to be also upgraded.

where is the fix? can you post a link please?

Simply upgrade to the latest version of Webmin

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.