VESTACP and Cloudflare -> Error: Let's Encrypt new auth status 429, rate limit, WHY?

Hi evreyone! Another rate limit in VESTACP here.

But I can’t find the problem, sorry. I have been actively searching for it aroung 1 week ago, and now I am desperate.

My domain is: encuentrovegano.es

I ran this command: Add a new domain to VESTACP as usual, and never gets a SSL certificate.

It produced this output:
Error: Let’s Encrypt new auth status 429

My web server is (include version):
vesta 0.9.8
Ubuntu 18.04 (64 Bit)

I use CloudFlare as DNS.

I can login to a root shell on my machine (yes or no, or I don’t know):
YES

I have already seen these websites, but I can’t still find why I got to the rate limit:


https://tools.letsdebug.net/cert-search?m=domain&q=encuentrovegano.es&d=168
https://www.ssllabs.com/ssltest/analyze.html?d=encuentrovegano.es&hideResults=on

Any help is really appreciated!!

Cheers!

Hi @lesudo

you have all you need. Read the output of https://check-your-website.server-daten.de/?q=encuentrovegano.es#ct-logs

Issuer not before not after Domain names LE-Duplicate next LE
CloudFlare Inc ECC CA-2 2020-04-08 2020-10-09 *.encuentrovegano.es, encuentrovegano.es, sni.cloudflaressl.com - 3 entries
Let’s Encrypt Authority X3 2020-03-24 2020-06-22 encuentrovegano.es - 1 entries

There is a certificate.

And it looks that you use it, because Cloudflare is able to connect your domain.

I don’t know what VestaCP is doing if you have a valid certificate.

Wait one hour, then the failed validation limit should be gone.

Then try it one time and see, if you can find a better log with the reason.

That

https://www.encuentrovegano.es/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de

Visible Content: check-your-website-dot-server-daten-dot-de.n_OifYyrIxXkmaZL3EZ2Uxk7U3SXnhPqTtScMCGBuDU

looks ok, that looks like a correct VestaCP answer.

Good: Acme-Check - Answer looks like a correct keyAuthorization - String: Filename + “.” + base64url(Thumbprint(accountKey)). So creating a Letsencrypt certificate using that integrated solution should work. Don’t use another client (like Certbot). Don’t mix integrated solutions with own ACME-clients, that may not work.

I solved it. Please delete this post, as I will publish a new post of how I did it but with no info of my client’s website.

Thanks @JuergenAuer

EDIT:

I already post the fix here:

PLEASE delete this post.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.