Timeout during connect (likely firewall problem)

Hi Guys,

I want to make a Nextcloud installation accessible from the outside. I succeeded, but I just can't get a valid certificate. I work with a VM in a Proxmox environment and have already tried a variety of ways. Without success. Now I have an installation with nextcloudpi on my server, but I have the problem below with all installations. My firewall is Ubiquiti's UDM and ports 80 + 443 are forwarded to the VM. I am grateful for any information.

Thank you.

My domain is: maltecloud.de

I ran this command: Click on Apply Button in nextcloudpi GUI for "Automatic signed SSL certificates"

It produced this output:
[ letsencrypt ] (Fri May 28 12:49:36 CEST 2021)
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for maltecloud.de
Using the webroot path /var/www/nextcloud for all unmatched domains.
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. maltecloud.de (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://maltecloud.de/.well-known/acme-challenge/2fn7xtVRUK_VeOJiS8WroKNtDOk27SRT5zk0g0NKziE: Timeout during connect (likely firewall problem)

  • The following errors were reported by the server:

Domain: maltecloud.de
Type: connection
Detail: Fetching
Timeout during connect (likely firewall problem)

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you're using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

My web server is (include version): Apache/2.4.38 (Debian)

The operating system my web server runs on is (include version): Debian Buster 10.9 in Proxmox VM

My hosting provider, if applicable, is: selfhost.de

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): nextcloudpi web gui

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.31.0

I can confirm the error presented by the Let's Encrypt validation server: there is almost nothing listening on the IP address it's port 80 and 443 completely inaccessible and/or firewalled off from the world wide web.

The only ports open are:

5060/tcp open sip
8089/tcp open unknown

1 Like

ok, now i'm totally confused. Assume port 80 and 443 are not open. Why do I then come to the Nextcloud GUI from the outside? A port scanner also says the ports are open:

http: //wwX.dnstools.chXport-scanner.html

Perhaps there is some kind of regional firewall in place. For example, other tools show your site as down:

1 Like

oh man, I almost went crazy in here. The magic word was regional. I had activated geo-filter in my firewall!

Thank you very much for the hint! Now it works!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.