Nextcloudpi timeout

I set up a Nextcloud Server via Nextcloudpi on a Raspberry Pi. I did that after my old configuration (nextcloud snap) stopped working after a software update on the Raspberry. The point is that I did not change port forwarding settings in my router worked. My DNS Server receives the correct IP address. I also tried sudo ufw enable 443 without success. Nonetheless, I get a “likely firewall problem”. What else can I do?

My domain is: https://ericsowncloud.ddns.net

I ran this command: NextcloudPi Configuration / Networking / letsencrypt / Start.

It produced this output:

Running letsencrypt
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for ericsowncloud.ddns.net
Using the webroot path /var/www/nextcloud for all unmatched domains.
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. ericsowncloud.ddns.net (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching https://ericsowncloud.ddns.net/.well-known/acme-challenge/rKSLvl5pZY5qstlVgDeDuyYuDJJrWR_8-FJQrVD_ViY: Timeout during connect (likely firewall problem)
IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: ericsowncloud.ddns.net
   Type:   connection
   Detail: Fetching
   https://ericsowncloud.ddns.net/.well-known/acme-challenge/rKSLvl5pZY5qstlVgDeDuyYuDJJrWR_8-FJQrVD_ViY:
   Timeout during connect (likely firewall problem)

 To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address. Additionally, please check that

your computer has a publicly routable IP address and that no firewalls are preventing the server from communicating with the client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

The operating system my web server runs on is (include version): NextcloudPi (Raspbian)

I can login to a root shell on my machine (yes or no, or I don’t know): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

Hi @Eric-Sommer

that’s simple - and the check of your domain created 01.11.2019 09:11:22 shows the same problem - https://check-your-website.server-daten.de/?q=ericsowncloud.ddns.net

You have ipv4- and ipv6:

Host T IP-Address is auth. ∑ Queries ∑ Timeout
ericsowncloud.ddns.net A 87.79.97.29 Cologne/North Rhine-Westphalia/Germany (DE) - NetCologne Gesellschaft fur Telekommunikation mbH Hostname: xdsl-87-79-97-29.nc.de yes 1 0
AAAA 2001:4dd6:9054:0:ddcb:ba4:a5dc:e5fe Cologne/North Rhine-Westphalia/Germany (DE) - NetCologne GmbH yes

But your ipv4 works, your ipv6 not. Ipv6 has a timeout. Letsencrypt prefers ipv6, so that’s critical.

  • Remove the ipv6, create a certificate, then fix your ipv6 (or, better)
  • fix your ipv6 directly.

But if it is a home server, your ISP and your router must support ipv6. And your webserver must have a Listen [::]:80 - directive.

1 Like

Thanks so much, the certificate has been created. Awesome :wink:

2 Likes