Timeout during connect (likely firewall problem)

Good afternoon,

I'm having some issues setting up the Let's Encrypt certificate and would appreciate any guidance or advice.

I'm trying to set up NextCloud (working fine locally) and link it to my subdomain.

I've forwarded ports 80 and 443 on both the server's firewall (via ufw) and on the router.

The DNS record seems to be correct ( Dig (DNS lookup) )

The domain was set up with Namecheap using their BasicDNS.

I've also tried with the router's firewall disabled but get the same error.

Thanks in advance for any advice.

My domain is: files.thegamesbuyer.com

I ran this command:
sudo nextcloud.enable-https lets-encrypt

It produced this output:
Timeout during connect (likely firewall problem)

The operating system my web server runs on is (include version):
Ubuntu 20.04.2 LTS

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

  • I'm not sure if it makes any difference but I used a self-signed cert before trying Let's Encrypt

I've been following this tutorial (How To Install and Configure Nextcloud on Ubuntu 18.04 | DigitalOcean)

Welcome to the community @JustForest

Before trying to get a cert you should ensure your server can be reached using HTTP. The Let's Debug test site is often helpful to start.

To me it looks like your firewall is blocking both ports 80 and 443.


Hi @MikeMcQ,

Thanks a lot for your reply.

I've set up forwarding for 80 and 443 in the router and "sudo ufw status" shows "80, 443 Allow, Anywhere". Any idea where I should be looking to unblock them?

1 Like

Perhaps the router has firewall options too?

Some residential ISPs block those ports too.


I found the issue - I had set the internal port as 8080 in the router instead of 80.

Now I just need to figure out how to get NextCloud pointing correctly to the subdomain, but I suppose that isn't a problem with Let's Encrypt :smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.