Stuck at Greengeeks


#1

I am stuck a green geeks and want to put SSL on each domain I have. Obviously it was a mistake going with them and now that I am outside the 30 day return policy I am stuck for a year
I have ssh acess. Can I make this work?

Please fill out the fields below so we can help you better.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hi @sdbish,

Is this a VPS where you are the only user on the server and have root access, or shared hosting where you are one of many customers hosted on the same system?


#3

It’s a reseller account. Where can I find data that would be helpful to you?


#4

Can you use sudo to run programs as root?


#5

Give me a test command I will try it.


#6

You could try running

sudo id


#7

Apparently I need to take a step back. While logged into my cPanel I do not see a command line. They are telling me that I have shell access, what am I missing?


#8

To use your shell access, you usually use an ssh client. This is a separate program from your web browser and the ssh process is not part of a web session.

Edit: although a minority of hosting providers that might indeed provide shell access of some kind within a web session.


#9

There is also a Let’s Encrypt plugin for cPanel; if they have it enabled, you might also be able to get and install Let’s Encrypt certificates from inside cPanel.


#10

I don’t see let’s encrypt activated in cPanel. What program should I use to access the shell?


#11

PuTTY is somewhat of a fan-favorite. It’s small, open-source, highly featured, and actively developed. https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html


#12

If you are using a Unix-like operating system on your computer, such as Linux or macOS, you also probably already have an ssh program installed that you can run from a terminal. PuTTY is probably still the most popular on Windows.


#13

Ok i got in with putty. I typed sudo id it said
-bash: sudo: command not found

So I typed in ID. It responded with UID, GID, groups etc.


#14

That likely means that your host doesn’t allow root access, which isn’t particularly unusual for shared hosting accounts. Certbot, unfortunately, requires root access. But fear not! There are a number of clients that do not require root. They’re not as far along the automation train, so you’ll probably have to manually renew the certs quarterly until you change hosts (I’m doing it now for a nonprofit I support who mistakenly went with a three year GoDaddy hosting agreement…ugh.) If all else fails, there are websites that integrate with Let’s Encrypt and provide you downloadable/copyable certs from LE that you can just paste into your hosting provider’s management page.


#15

I have been able to mess around in there a little bit and tried tge commands to install certbot. The install command worked but the certbot auto apache did not work.
Ok if this is not going to work please give me a step by step on how to get this done another way without breaking the bank.


#16

@sdbish, you should first double-check that there is somewhere that the web host allows you to install a certificate that you obtain from a certificate authority. If they don’t let you do this (or they charge money for the process that you’re not willing to pay), there is nothing that we can do about that because it’s simply a matter of hosting provider policy.

For example, there’s a rather popular host called HostGator that requires people to interact with their support to install certificates, and charges $10 each time for the process (making Let’s Encrypt a bad financial option for HostGator users because even though our certificates are totally free, the hosting provider’s install charges add up to more than the price of a longer-lived paid certificate from another certificate authority).

You should also consider that in a shared hosting environment like this, you will probably have to do something every time the certificate is going to expire in order to install a new one. With Let’s Encrypt, that’s every three months (and we recommend trying to renew the certificate every two months, in case anything goes wrong). If the sudo command had worked, there would have been an option to automate this process entirely; since it didn’t, there probably isn’t.

If you’re OK with all of that, we can give you some options—the easiest might be the web site https://zerossl.com/, which gets Let’s Encrypt certificates for you inside your web browser.


#17

As another option, if you could persuade Greengeeks to turn on Let’s Encrypt support for you in cPanel, then you could do this from inside cPanel (and I think the renewals would also be automated, if I remember correctly how that works). They probably have the ability to do this if they’re willing to.


#18

Sorry to inform you that , Let’s Encrypt is not supported Currently and we are working on the integration of Let’s Encrypt on our servers and it will be available soon.

That’s what they said when I asked them to turn it on in c panel.

I am dissappointed. Unless you want to pm me and I will give you whatever info you need to login and you can check it out yourself to verify, then I need a solution. If they’re not lying to me it may be a temporary solution, but nonetheless I need a solution.


#19

You can still use Let’s Encrypt certificates, you just need to generate them from somewhere outside of your server. For example the ZeroSSL site that @Schoen linked. You’ll just need to manually paste the certificate into their management page. In all likelihood (barring caveats like the example regarding HostGator), this shouldn’t be a problem. The phrasing of that support response indicates simply that they do not yet have cPanel integration to manage Let’s Encrypt certificates automatically. It does not indicate that you can’t get load a Let’s Encrypt certificate manually.


#20

I found this on the knowledge base
https://www.greengeeks.com/kb/3777/how-do-i-create-a-key-and-csr-for-an-ssl-in-cpanel/
So do I somehow use that zeroSSL Inconjunction with The link above?