SSL certificate installed, website can't be viewed on HTTPS


#1

I have installed certbot SSL certificate on Linode server,
also set up vhost and already rebooted the host.

I can view the website as normal under http,
however, it doesn’t work when browsing under https.

Please help as I cannot seem to find where the problem is.

Below is my vhost setting

<VirtualHost *:80>
ServerAdmin admin@xxxx.com
ServerName mydomain.com
ServerAlias mydomain.com
DocumentRoot /srv/www/mydomain.com/html

<Directory "/srv/www/mydomain.com/html/">
    Options FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

ErrorLog /srv/www/mydomain.com/logs/error.log
CustomLog /srv/www/mydomain.com/logs/access.log combined
ServerSignature Off
</VirtualHost>

<VirtualHost *:443>
ServerAdmin admin@xxxx.com
ServerName mydomain.com
DocumentRoot /srv/www/mydomain.com/html
SSLEngine On
SSLCertificateFile /etc/letsencrypt/live/mydomain.com/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/mydomain.com/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateChainFile /etc/letsencrypt/live/mydomain.com/chain.pem

<Directory "/srv/www/mydomain.com/html/">
    Options FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

ErrorLog /srv/www/mydomain.com/logs/error.log
CustomLog /srv/www/mydomain.com/logs/access.log combined
ServerSignature Off
</VirtualHost>

#2

Can you provide a bit more information? What kind of error are you getting? Do you have “listen 443” somewhere in your apache config? Do you have a firewall blocking 443? do you get an ssl error in your browser?


#3

Thank you for your reply.
there is another setting in “ssl.con” () .
I remove it and restart httpd , now it works.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.