How to debug https connection problem?

I got my ssl certificate and added the following sections to my httpd-vhost.conf file.

<VirtualHost mydomain.com:443>
     ServerAdmin admin@mydomain.com
     DocumentRoot "/opt/lampp/htdocs/mydomain"
     ServerName mydomain.com
        SSLEngine on
        SSLCertificateKeyFile /opt/lampp/etc/mydomain.com.key
        SSLCertificateFile /opt/lampp/etc/fullchain.cer
     ErrorLog "logs/www.mydomain.com-error_log"
     CustomLog "logs/www.mydomain.com-access_log" common
</VirtualHost>

The apache server restarted OK. But when I tried to access the website using https, it says.

This site can’t be reached
www.mydomain.com refused to connect.

Where can I see more information about what’s wrong? Neither logs/www.mydomain.com-error_log nor logs/www.mydomain.com-access_log even show anything about my attempt to connect through https.
Thank you.

Try change this to

<VirtualHost *:443>

Since you are using name-based virtual hosting, I don’t think there’s any point binding to specific address.

Also make sure that apachectl -t actually reports success. Sometimes it “restarts successfully” but not really.

Changing to *:443 and restart still gives same result. “apachectl -t” says Syntax OK but I think it is not looking at my actual apache config because I am using LAMPP and I don’t know the equivalent command. I restart apache with the following command.

/opt/lampp/lampp restartapache

XAMPP: Stopping Apache…ok.
XAMPP: Starting Apache…ok.

Is there any kind of log file that will show me what is happening when I try to access the site through https? Now I only see mydomain.com refused to connect in browser. That doesn’t tell me much.
Also I actually have a couple different VirtualHost blocks in the httpd-vhost.conf file with different domain names. If I use *:443 I can’t distinguish them anymore.

EDIT: BTW, the site is wordpress, does that make any difference?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.