Trying to install certificate


#1

Home server running Ubuntu 14.04 and Apache2, I used the webroot version of Lets Encrypt and it worked.

I then edited my Virtual Hosts File and added a section for port 443

I opened up port 443 on my router and nmap appears to show that it is open

And yet when I go to https://www.onlinedegreedatabase.com, I get a SSL connection error.

Any suggestions as to what I have missed?

Thanks in advance,

Doug


#2

I’d suspect you haven’t added the SSL cert info correctly - as it’s listening with http not https on port 443


#3

Thanks - here is what I have in the virtual host

<VirtualHost *:443>

    ServerAdmin d.f.stoll@gmail.com
    ServerName onlinedegreedatabase.com
    ServerAlias www.onlinedegreedatabase.com
    DocumentRoot /var/www/html/project.com
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

SSLEngine on
SSLCertificateFile /etc/letsencrypt/live/onlinedegreedatabase.com/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/onlinedegreedatabase.com/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/onlinedegreedatabase.com/fullchai$


#4

Interesting - that looks OK.

I assume you have < VirtualHost *:443 > before and < /VirtualHost > at the end ? and you reloaded apache


#5

I had the brackets, but had only restarted Apache, not reloaded it. And reloading just worked. Thanks a lot for your help!


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.