Domain doesn't work after Lets Encrypt

Hey,

I added SSL certificate via Let’s Encrypt and I followed this guide But now, my site does’t open :frowning:

My domain is: evinterneti.online

I ran this command: sudo certbot --apache -d evinterneti.online -d www.evinterneti.online

It produced this output:

My web server is (include version): Apache 2

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Port 443 may be closed/blocked by firewall.
curl -Iki https://www.evinterneti.online/
curl: (7) Failed to connect to www.evinterneti.online port 443: Connection timed out

Port 80 connects and shows proper redirection for both: http://evinterneti.online/ & http://www.evinterneti.online/

1 Like

Please show:
apachectl -t -D DUMP_VHOSTS
and:
netstat -pant | grep apache
[if empty, then: netstat -pant]
[if too many, then: netstat -pant | grep -i listen]

1 Like

alibaraneser@instance-1:/etc/apache2/sites-enabled$ apachectl -t -D DUMP_VHOSTS
AH00112: Warning: DocumentRoot [/var/www/html/public] does not exist
AH00112: Warning: DocumentRoot [/var/www/html/public] does not exist
AH00526: Syntax error on line 17 of /etc/apache2/sites-enabled/evinterneti.online-le-ssl.conf:
SSLCertificateFile: file ‘/etc/letsencrypt/live/evinterneti.online/fullchain.pem’ does not exist or is empty
Action ‘-t -D DUMP_VHOSTS’ failed.
The Apache error log may have more information.

alibaraneser@instance-1:/etc/apache2/sites-enabled$ netstat -pant | grep apache
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)

1 Like

Please show this file:

and output of:
certbot certificates

and now with sudo:
sudo netstat -pant

1 Like

I solved problem.

I apply “Allows Https Traffic” on the Google Cloud Platform. Thanks for reply :slight_smile:

2 Likes

So my first sentence in my first post solved your problem - your welcome.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.