Let's Encrypt Issue while requesting certificate for my domain

My domain is: live.**************.org

I ran this command: certbot certonly -d live.**************.org

It produced this output:

My web server is (include version): Apache/2.4.52

The operating system my web server runs on is (include version): Ubuntu 22.04

My hosting provider, if applicable, is: godaddy

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 2.8.0

I am facing this issue for the last 3 days, i am not able to get the certificate. Can anyone help me on this how to get rid of this. I even tried this command "certbot certonly --cert-name live.**************.org" but unfortunately the same error appears again and again.

Looking forward to hearing from you people for my topic.

Thanks in advance.

Without the domain name there is not much specific we can say. The error message says that the connection using HTTP to your domain is timing out. This is almost always because of a firewall. So you should check those settings. If you have any other port assignment or forwarding you should check those too.

A good site for testing changes is


Are you able to reach your domain with HTTP from outside your local network? Like using a mobile phone with WiFi turned off so you are using your carrier network.


Hi Mike,

Thanks for taking your time to reply to my topic. But i would like to say one more thing that I am running 2 more environments like (staging and production) on the same EC2 instance. Whereas only staging environment uses Let's Encrypt. So, here I am deploying one more pre-prod environment for another website. So I am using Let's Encrypt. I am wondering how the other 2 websites environments as I mentioned earlier are working fine with the firewall which is already defined with port 80 and port 443 along with the MySQL port 3306. I hope and guess this is nothing related to firewall. I am telling this because other 2 websites are running without any errors.

Looking forward to hearing from you.

1 Like

Staging and production are behind one single IP?


Something is blocking HTTP requests to your domain name. But, as I said without the actual domain name there is not much more we can help you with.

You need to test connectivity to that domain name from the public internet. Did Let's Debug test site return an "OK" result? What about a device outside your AWS VPN? Like a mobile phone with wifi off or some home device or something? Do HTTP (not HTTPS) requests work?


Yes! @rg305


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.